Home General Discussion
Automatic "Save Draft" has been disabled temporarily. This means comments are not being auto-saved as you type.

Drafts can be manually saved whenever the "Save Draft" button is clicked.

We're chasing down a bug, and we'll let you know when autosave is re-enabled. Thanks!

just finished unreal 2

1
Ruz
ngon master
Offline / Send Message
Ruz ngon master
well its a bit late,as I first played the game in 2003, but finally I finished it. did it in about 3 days on and off.
noticed kevin johnstone did the character work)
bit disappointing overall, the textures sooooo low res, even on highest settings.

I might play some more old games now as I can't even install gears of war.

Replies

1
Sign In or Register to comment.