Home Adobe Substance

Substance Painter - Baking - Mesh wont bake half the maps

polycounter lvl 3
Offline / Send Message
Pinned
GarethStandfield polycounter lvl 3
Heya everyone this mesh has been the bane of my existence for almost three days! every option iv googled has not fixed it.

So it was fine to begin with, nothing wrong. I went and edited the AO map as it was pretty borked and made it serviceable, come to rebake the normal's ect and boom the main body mesh will not bake anything at all, i then re export it and try again, now it bakes the normal, the normal world space and the ID and the "position" but the position map is blank, the AO - thickness and currviter maps just dont even bake, as you can see in the picture the positions like blank?

I have no clue whats going on, iv tried OBJs FBX deleting and renaming every texture, redoing all the UVs and nothing is working at all. Im stumped. Anyone have any clue whats going on?

Also i have checked all the UVs are inside the first square non are outside which apparently can cause this. 



This is the log btw!

Replies

  • icegodofhungary
    Offline / Send Message
    icegodofhungary interpolator
    The FBX has a single material applied right? Might want to throw it back in your modeler, select all, apply a material, then export it. If you have multiple materials applied, you have to bake each material set separately. When you go into your bake mesh maps the option at the bottom right will let you select which material sets to bake so that would let you know you have multiple sets going on too.
  • GarethStandfield
    Offline / Send Message
    GarethStandfield polycounter lvl 3
    The FBX has a single material applied right? Might want to throw it back in your modeler, select all, apply a material, then export it. If you have multiple materials applied, you have to bake each material set separately. When you go into your bake mesh maps the option at the bottom right will let you select which material sets to bake so that would let you know you have multiple sets going on too.
    The FBX has three mats, one for the head, one for the body, and one for the weapon and utilities which is the way from my understanding you separate different uved maps in substance.

    The utilities and the Head map bake perfectly, and so did this one at one point now it does not.

    I have tried baking it on its own and the same issue arose? really confusing issue :(

    This is what the log shows btw




  • poopipe
    Online / Send Message
    poopipe high dynamic range
    The log says It can't load the high res mesh - which it needs to perform any of the 'from mesh' bakes
    Is it actually where you told painter it is? 
    Have you changed it?  
  • GarethStandfield
    Offline / Send Message
    GarethStandfield polycounter lvl 3
    poopipe said:
    The log says It can't load the high res mesh - which it needs to perform any of the 'from mesh' bakes
    Is it actually where you told painter it is? 
    Have you changed it?  
    Took abit but figured it out.

    For this too work i had to turn off "Enable ray tracing from GPU" in the settings window for baking, im guessing the density of the mesh made ray tracing just stop the program from hammering my gpu into the ground but had no way to tell me that other then the mesh could not be loaded. 

    Cheers for the help, what an odd problem haha. 
Sign In or Register to comment.