Home Unreal Engine

[UE5] Nanite not enough detail (Trangles in Nanite view are too large)

Offline / Send Message
OccultMonk interpolator

Culling starts too soon resulting in clearly visually triangulated geometry (something that should be round getting straight corners), Triangles (in Nanite view) are much larger than the surrounding rocks of the valley of the ancient environment. At a close range the mesh looks great, but when I move a bit further culling becomes too obvious. It's a 300MB Decimated Zbrush mesh (so there is quite a bit of detail in there). I have a 3090GTX and 5950x 16 core CPU with 64GB Ram. 

I tried with different import scale for the mesh and also tried maximum settings for the Nanite Position Precision setting of the static mesh. I even set the .INI file for Nanite on higher settings:



  • OccultMonk
    Offline / Send Message
    OccultMonk interpolator
    r.Nanite.MaxPixelsPerEdge = 0.5 Prevents the worst culling scene wide. But The meshes still have too large triangles compared to other meshes in the scene. It’s still very unclear to me why Nanite decides to give some meshes larger triangles than other meshes. Why it culls some geometry more.

    The import scale setting in the import dialog should influence Nanite, But it does not seem to do anything for nanite triangulation when I tried to set it at 50. (The Mesh is obviously larger) Maybe the size of the mesh in the FBX file itself should be larger, and Nanite does not look at the import scale in the import dialog?
Sign In or Register to comment.