SOLVED: 3DS Max 2016 Cloning objects destroys mesh

polycounter lvl 4
Offline / Send Message
gfelton polycounter lvl 4
About to move onto retopo after finishing a high poly, went to go simply clone my objects and upon doing so, I get this result:
As you would imagine, it's *kind of* frustrating. Again, this is only after doing the clone function on ~9 pieces of geometry.


  • gfelton
    Offline / Send Message
    gfelton polycounter lvl 4
    I was thinking maybe cloning so much geometry (low + turbosmooth) was what was causing this, tried turning it off then cloning and had no luck :/
    EDIT: Problem solved, turned out the two objects that were bugging out were proboolean products that had edit poly + turbosmooth modifiers on top of each other, simply collapsing to the edit poly's fixed the issue.
  • huffer
    Offline / Send Message
    huffer interpolator
    In the future, try to collapse Edit Poly's as soon as possible, or you might open the scene and see your mesh corrupted!
  • Mark Dygert
    Yep. Keep in mind that the modifiers higher in the stack are dependant on things lower in the stack, especially when it comes to edits made to faces and verts and edges.

    ProBooleans have internal operations that can change the topology and reorder the vert index table trying to create the best geometry possible. Even just opening a file could trigger ProBoolean to reevaluate the topology and renumber the verts. So can clicking on it in the stack and it will most certainly reorder everything if you move an operand. 

    The things higher in the stack are still operating on the specific verts but now they are in different places. Vert1 could have been on a rivet originally but now vert1 is in a totally different place, but the history of what happened to vert1 is still being applied, giving you crazy topology.

    So yea if you're going to start editing the topology it's probably best to duplicate the mesh and collapse the stack to keep those modifiers from causing problems.

Sign In or Register to comment.