Home Unreal Engine

Tileable Normal Map Causing Incorrect Hard Shadows After Light Map Bake


I've been having an issue with a tileable normal map in UE4. Whenever I bake the lighting, I end up with this result:

The light map for this asset is correct as it has plenty of spacing and no overlapping UVs, so I know it isn't a lightmap issue. The only way I have been able to make the problem go away was to disconnect the normal map in the material editor, creating this result:

I applied the material (with the normal map reconnected) to some other objects, baked the lighting, and got a similar strange results:

Interestingly, when I tried using a completely different normal map in my material, the issues went away, as can be seen here:

I checked, and as far as I can tell, there are no differences between the settings of the two normal maps. I also tried flipping the green channel on the original normal map, but that didn't change anything. Another solution I pursued was to use the supplied height map instead. My setup in the material editor can be seen below, however, I still got the same strange hard shadow.

I also tried disconnecting the AO map, but to no avail. In case anyone's curious, I'm using UE4 4.27.2. Despite extensive internet searching, I haven't been able to find a solution this this issue. Any thoughts?


  • Fennec_Raptor
    Offline / Send Message

    While, I ultimately did find a ‘solution’ to this problem. The only issue is that it might not be a great option for everyone. In the end, I just downloaded a different PBR material that fitted my needs better anyway. This new material doesn’t seem to present any of the same issues, so based upon this and what I encountered while trouble shooting (see above post), I think there was just something wrong with the normal map from the old material. Anyway, hopefully someone will find this useful in the future.

Sign In or Register to comment.