Home Unreal Engine

UE4: textures looking fine on my comp, but blurry on other computers?

polycounter lvl 12
Offline / Send Message
Cg_Creator polycounter lvl 12

Hi,

After I package my game, everything looks fine on my computer, but when I try it on other computers, some textures are blurry??

Does it have to do with the graphic card, drivers, or some updates missing or plugins?

I ll will send pictures to show the issue, but some textures are fine and some are insanely blurry, the game still run fine, but some textures just don't come out as they should...?

Thanks

Replies

  • Alex_J
    Options
    Offline / Send Message
    Alex_J grand marshal polycounter

    Is the game running a benchmark and thus changing the scalability settings for other hardware?

  • rollin
    Options
    Offline / Send Message
    rollin polycounter

    Do the other computers have less video RAM then yours?

  • Cg_Creator
    Options
    Offline / Send Message
    Cg_Creator polycounter lvl 12

    Hi guys, thanks for the tips, by changing the textures to no mip map it fixed it... it s weird that it would work on my computer but not on others. Anyway problem fixed, thanks for the help

  • poopipe
    Options
    Offline / Send Message
    poopipe grand marshal polycounter

    Don't tell them to not mip, it's not fixing the problem, pisses memory away and will slow everything down.

    Most likely they're not streaming in because pool sizes are set too low but that's just a guess.

  • Cg_Creator
    Options
    Offline / Send Message
    Cg_Creator polycounter lvl 12

    Well I do have a pool streaming message on screen that i turned off... Everything works fine, but if I wanted to do it the right way, what should I do ?

  • poopipe
    Options
    Offline / Send Message
    poopipe grand marshal polycounter

    it depends what's causing it, ive given you the most obvious reason - the solution to which is to not use lots of big textures or increase the poolsize.

    disabling mips will increase memory usage, cause rendering artefacts and slow down texture sampling.


    there's no guarantee thats the reason of course. To determine the cause you have to test and profile. there's lots of tools built into unreal for that and I'd suggest you start by looking at how much gpu memory you're using.


    if you're distributing builds you'll need to set up profiles for the target platforms or it'll just pull your editor settings/some defaults - this stuff is documented but its confusing so be prepared to start googling.

Sign In or Register to comment.