Home Marmoset

Blender to Marmoset and The Mystery of Flying Vertex.

So i made animation for my fish character in Blender. I used Rigify add-on for the rig and then did the key frames etc... Then I started to render it in Marmoset Toolbag 4, but when I played the animation in Marmoset, one vertex starts to fly around. This is odd because the animation is fine in Blender. So I tested and removed this vertex and imported it again to Marmoset, but again another single vertex starts to fly around. Both of these vertexes are in the same vertex loop at the neck area. I'd hate to rig and animate this thing again so does anyone have any ideas whats going on and how I could solve this?



Marmoset toolbag 4

 

Blender



Replies

  • EarthQuake
    A good way to tell if this is an export issue (ie: a problem with the application exporting the data) or an import issue, is to import the animation back into the first app and try importing it into another application as well, such as Unreal, Unity, Max, Maya, etc, to see if the vertex problem is isolated to Toolbag or if you're seeing it in other apps.

    If you're only seeing it in Toolbag, please email [email protected] with a description of the problem and the FBX file so we can debug it.
  • Vexod14
    Offline / Send Message
    Vexod14 interpolator
    I've got this since 3.04 along with other anim problems related to scale. This wasn't there on Toolbag 3.03, so if you have no luck and got this bug but definitely want to render with Toolbag, simply downgrade to 3.03.


    I've personnally tested my exports on different versions of toolbag (each version since animation support has been around), from 3.04 to 4.02 these issues appears regularly, not on every mesh but it's not a rare thing. I've also tried to read apparently issued files with FBX review, Maya, both didn't had this issue and no scale problem popped out, so the bug has definitely to deal with toolbag. I don't know when the 4.03 will come out but I hope once again these bugs will be fixed.

    Cheers (and don't take it as a big concern, I still love using Marmoset a lot ♥)
  • MoistMittens
    Vexod14 said:
    I've got this since 3.04 along with other anim problems related to scale. This wasn't there on Toolbag 3.03, so if you have no luck and got this bug but definitely want to render with Toolbag, simply downgrade to 3.03.


    I've personnally tested my exports on different versions of toolbag (each version since animation support has been around), from 3.04 to 4.02 these issues appears regularly, not on every mesh but it's not a rare thing. I've also tried to read apparently issued files with FBX review, Maya, both didn't had this issue and no scale problem popped out, so the bug has definitely to deal with toolbag. I don't know when the 4.03 will come out but I hope once again these bugs will be fixed.

    Cheers (and don't take it as a big concern, I still love using Marmoset a lot ♥)

    I downloaded 3.03 and it solved the problem! Thank you very much!
  • EarthQuake
    Vexod14 said:
    I've got this since 3.04 along with other anim problems related to scale. This wasn't there on Toolbag 3.03, so if you have no luck and got this bug but definitely want to render with Toolbag, simply downgrade to 3.03.


    I've personnally tested my exports on different versions of toolbag (each version since animation support has been around), from 3.04 to 4.02 these issues appears regularly, not on every mesh but it's not a rare thing. I've also tried to read apparently issued files with FBX review, Maya, both didn't had this issue and no scale problem popped out, so the bug has definitely to deal with toolbag. I don't know when the 4.03 will come out but I hope once again these bugs will be fixed.

    Cheers (and don't take it as a big concern, I still love using Marmoset a lot ♥)
    I'm not sure if we have this logged in our bug system, so if you can email an example FBX file that shows the vertex problem to [email protected], we'll look into it. Thanks
  • MoistMittens
    Vexod14 said:
    I've got this since 3.04 along with other anim problems related to scale. This wasn't there on Toolbag 3.03, so if you have no luck and got this bug but definitely want to render with Toolbag, simply downgrade to 3.03.


    I've personnally tested my exports on different versions of toolbag (each version since animation support has been around), from 3.04 to 4.02 these issues appears regularly, not on every mesh but it's not a rare thing. I've also tried to read apparently issued files with FBX review, Maya, both didn't had this issue and no scale problem popped out, so the bug has definitely to deal with toolbag. I don't know when the 4.03 will come out but I hope once again these bugs will be fixed.

    Cheers (and don't take it as a big concern, I still love using Marmoset a lot ♥)
    I'm not sure if we have this logged in our bug system, so if you can email an example FBX file that shows the vertex problem to [email protected], we'll look into it. Thanks
    I emailed the file to Marmoset support. I also tried to make new animation but same problem at the same spot. I didn't use new rig though.

Sign In or Register to comment.