Home Technical Talk

[Maya 2018] Re-generating vertex & poly normals?

polycounter lvl 10
Offline / Send Message
FiftyTifty polycounter lvl 10
I finally figured out what was wrong with my mesh, when exporting it as FBX and punting it into UE4. I'm so close, but have hit a snag. The normals are screwed for the top half of the head mesh, where its split and the vertices are doubled. Or at least, I assume so, since the issue with the mesh in game looks just like an issue with normals: https://cdn.discordapp.com/attachments/505163611203960842/823681609987129434/unknown.png

Here's the scene, unskinned mesh, and the current .fbx exported from the scene: https://drive.google.com/file/d/15RydGN5M-UHpJlDbpbadHpeyFuy-mCFw/view?usp=sharing

I can't find anything to generate normals with. Display them, sure. But no re-computing normals, no unifying normals, etc. It'll be in some hidden menu, but I can't seem to find it.

Replies

  • Joopson
    Options
    Offline / Send Message
    Joopson quad damage
    Normal editing tools are under the Mesh Display dropdown.
    You'll potentially need to unlock normals first before doing anything else, depending on what you've done with the mesh beforehand.

  • FiftyTifty
    Options
    Offline / Send Message
    FiftyTifty polycounter lvl 10
    Joopson said:
    Normal editing tools are under the Mesh Display dropdown.
    You'll potentially need to unlock normals first before doing anything else, depending on what you've done with the mesh beforehand.


    Ahh, somehow I missed that. I spent a bunch of time redoing the normals, softening, hardening, conforming, etc. And the issue is the exact same.


    I genuinely can't figure this out. The normals are all pointing outward, and aren't wonky or anything.

  • Joopson
    Options
    Offline / Send Message
    Joopson quad damage
    My money's on the FBX export settings, and the import settings to UE4 as well, potentially.

    Look at some Maya-to-UE4 documentation to see what settings are and are not recommended for exporting; and also, what import settings are recommended in UE4 for this type of mesh.

    This section of the documentation addresses a lot, and may help.
    https://docs.unrealengine.com/en-US/WorkingWithContent/Importing/FBX/index.html
  • FiftyTifty
    Options
    Offline / Send Message
    FiftyTifty polycounter lvl 10
    Joopson said:
    My money's on the FBX export settings, and the import settings to UE4 as well, potentially.

    Look at some Maya-to-UE4 documentation to see what settings are and are not recommended for exporting; and also, what import settings are recommended in UE4 for this type of mesh.

    This section of the documentation addresses a lot, and may help.
    https://docs.unrealengine.com/en-US/WorkingWithContent/Importing/FBX/index.html

    I've been trying all sorts of settings. But no matter how I combine them, what I turn off, what I turn on, whether only normals/tangents are imported/generated, it still causes the visual error.

    These are the import settings as dictated by Funcom when importing a mesh skinned to the human skeleton: https://i.imgur.com/W7PPUed.png

    Trying either of them, as well as combining the settings, doesn't fix anything. The top half of the head is still pitch black. I've asked around on their Discord, but nobody has any idea.

    Edit: So I redid the whole mesh, starting from scratch. Now the mesh is fine and doesn't have that black shading. I genuinely don't know why it did that.
  • sprunghunt
    Options
    Offline / Send Message
    sprunghunt polycounter
    Have you looked at the normals on the mesh? If you select the mesh and go to the shape tab in the attribute editor underneath "mesh component display" there's a checkbox "display normal". You can check this on and set the dropdown below it to "vtx" and it will draw the normals as lines on screen. 

    Then you'll be able to see if you have the normals pointing the wrong way or if they're locked or something. 
  • FiftyTifty
    Options
    Offline / Send Message
    FiftyTifty polycounter lvl 10
    Have you looked at the normals on the mesh? If you select the mesh and go to the shape tab in the attribute editor underneath "mesh component display" there's a checkbox "display normal". You can check this on and set the dropdown below it to "vtx" and it will draw the normals as lines on screen. 

    Then you'll be able to see if you have the normals pointing the wrong way or if they're locked or something. 

    That's the thing. The normals are all pointing in the right direction. I've done a bunch of work on another mesh, and the issue arose again. I'm pretty sure it's happening because I welded vertices together around a seam, which throws UE4 for a loop.

    Is there a way to re-split vertices, like some sort of export option? Cause it's gonna be a pain to do 2 hours of work all over again.

    Edit: Ah bloody hell, even just importing the mesh then exporting it causes the issue. This is getting on my nerves now.

    Edit2: Turns out the problem was not having "Use T0As Ref Pose" ticked. The import settings were reset somehow. Whew.
Sign In or Register to comment.