Home Marmoset

Importing .fbx sets model back to T-Pose. Why?

polycounter lvl 7
Offline / Send Message
Sreliata polycounter lvl 7
'Ello, lovely world of the polycount marmoset interwebs.

Let's get to the point.

1. Setting up a scene in blender, including stage, model and camera.
2. Exporting said scene with the posed model (posed armature) as .fbx.
3. Importing .fbx into marmoset. The model is back in T-Pose. Even if I apply transformation in the exporting options.

Why?

The only workaround was to click on every single mesh (head, clothing, fingers etc.) and apply the armature in the modifiers, so that it's basically removing the 'skeletton' completely. Is there no way to export an .fbx scene and import it into Marmoset, without losing all the posed information? 

And since we're at it: does anyone know if there is a passerpatout option in Marmoset? Aka: an outlining of what the camera will see before I hit 'Render'?

Replies

  • EarthQuake
    I'm not familar with Blender's export settings, but I would check to make sure you're exporting with animation enabled and if there are any settings like "bake animation" try enabling that too. When you import your FBX, do you see the Model Animation panel? If so check the Current Animation dropdown and see if you can select your pose there.

    For the camera, go to the camera object and enable Safe Frame in the Lens panel.
  • Sreliata
    Offline / Send Message
    Sreliata polycounter lvl 7
    I'm not familar with Blender's export settings, but I would check to make sure you're exporting with animation enabled and if there are any settings like "bake animation" try enabling that too. When you import your FBX, do you see the Model Animation panel? If so check the Current Animation dropdown and see if you can select your pose there.

    For the camera, go to the camera object and enable Safe Frame in the Lens panel.
    Ah! Thank you so much for the 'safe frame' in the lens panel. I had no idea that's the thing I wanted but it is!! Much appreciated.

    As for the rest? It's not an animation I want to import, it's a still render, with a posed armature /skeletton and that, for some reason, just won't work in FBX. It works just fine in .obj but not in .fbx. Which is sad because camera settings and such only work in .fbx import.

    The armature /skeletton isn't even imported with the .fbx. Is it not possible to get a posed model into marmoset, unless it's exported as a wavefront object?  :'(

     
  • EarthQuake
    Sreliata said:
    I'm not familar with Blender's export settings, but I would check to make sure you're exporting with animation enabled and if there are any settings like "bake animation" try enabling that too. When you import your FBX, do you see the Model Animation panel? If so check the Current Animation dropdown and see if you can select your pose there.

    For the camera, go to the camera object and enable Safe Frame in the Lens panel.
    Ah! Thank you so much for the 'safe frame' in the lens panel. I had no idea that's the thing I wanted but it is!! Much appreciated.

    As for the rest? It's not an animation I want to import, it's a still render, with a posed armature /skeletton and that, for some reason, just won't work in FBX. It works just fine in .obj but not in .fbx. Which is sad because camera settings and such only work in .fbx import.

    The armature /skeletton isn't even imported with the .fbx. Is it not possible to get a posed model into marmoset, unless it's exported as a wavefront object?  :'(

     
    To export a rigged, posed model via FBX you will generally need to export it as an animated file and include the skeletal data - even if there is no animation. If you don't include the skeletal data, Toolbag will not be able to deform the mesh into the pose you've set up. As you've found, you can bake down or apply the pose directly to the mesh before exporting if you want to avoid including the skeleton.

    OBJ does not support skeletal data so it is likely that Blender is baking the pose when you export it. There may be an export option in Blender to do this for FBX files too, I'm not much of a Blender user so I can't provide any more advice there. You might try asking on the Blender forums.
Sign In or Register to comment.