Home Unreal Engine

[SOLVED] Textures disappearing in (some) Material Instances

polycounter lvl 9
Offline / Send Message
Temppe polycounter lvl 9

I'm trying an interior viz project to get my hands dirty with UE4. It's my first real project using the engine. The issue is that I made a master material to cover most of my material needs. Now, some of the material intances are showing up the generic gray boxes instead of the texture maps.

In the first image, there should be four material instances visible. But only one of them is working (which is the first instance I made, it that matters).

The second image is of the master material. I dunno if there's any point putting this here, since if one of the instances works, I doubt the problem is here. It's pretty standard - texture maps and some adjustments, all made into parameters.

The third image is two of the instances. The brick one works fine. The concrete one, which used to work, shows the generic gray boxes in the scene.

Here is some more info that I think might point towards the answer.

1. All the instances used to work fine, but I tried to add displacement functionality to the master (and displacement maps to the brick instance) and then noticed the issue. I removed the displacement functionalty from the master but the issue persists.
2. Any new instances of the master have the same issue.
3. I created a totally new super basic master material, created an instance of it and used the *same* maps that aren't showing with the original material/instance and it works.
4. At some point yesterday I briefly saw a warning about texture pool size but can't get it to reappear. I searched this online and found some console commands that increase it but they made no difference. I should mention that I don't really know much about what texture pool size is, to be honest. I hunted online and found a console command that allegedly increased the size, but it had no effect.

Any help would be appreciated so much.


  • fangazza
  • Temppe
    Offline / Send Message
    Temppe polycounter lvl 9
    Hey hey!
    Thanks a lot for replying. I was actually half way through the archviz series on materials and forgot to look at other series. That one is much more technical - just what I need.

    So I now know that it's definitely NOT the texture pool size... still don't know what's causing the issue though.
  • Temppe
    Offline / Send Message
    Temppe polycounter lvl 9
    Okay, so I finally got the output log running instead of the popup console and I can see the following message (in fact, a few of them for different meshes):

    LogStaticMesh: Warning: Adjacency information not built for static mesh with a material that requires it. Using default material instead.
        Material: /Game/Materials/brushed_aluminium/MI_brushed_aluminium.MI_brushed_aluminium
        StaticMesh: /Game/scene_01/Geometries/floor.sm_floor

    I'm going to scour the web for information on this, of course if anyone can shed some light here that would be great!

  • Temppe
    Offline / Send Message
    Temppe polycounter lvl 9

    I open the static mesh editor, in LOD0 -> build settings, I tick "build adjacency buffer". Problem solved.

    I have no idea what the adjacency buffer is. When you go from the likes of Vray to a real time engine, there's so, so much more technical stuff you need to learn, such as this... gonna take me a while!
Sign In or Register to comment.