Home Marmoset

Can't get textures/materials to show

DustyShinigami
polycounter lvl 4
Offline / Send Message
DustyShinigami polycounter lvl 4
Hi

I'm kinda new to Marmoset Toolbag, but I'm having a problem getting my textures/materials to show. I've exported the model out of 3ds Max with all it's materials - both FBX and OBJ - but neither load up the textures when I import the model in. Even importing the MTL file via Material doesn't do anything. All the materials remain blank or are metallic looking. Can anyone help or suggest what I might be doing wrong? Thanks.

Replies

  • EarthQuake
    Toolbag will attempt to import textures if the mesh/material stores references, however, what is supported by OBJ and FBX is rather limited, and what will be exported may vary with different 3D apps. You will likely need to set up your material and load some or all of your textures manually.

    This is a good place to start: https://marmoset.co/posts/toolbag-3-scene-setup/
  • DustyShinigami
    Offline / Send Message
    DustyShinigami polycounter lvl 4
    Thanks for the reply. Two of those texture boxes from the video are working, however my Albedo isn't showing for some reason. The colour remains grey.

    EDIT: Wait, never mind. I think I've got it. I have to set the Reflectivity from Specular to Metalness. :D
  • DustyShinigami
    Offline / Send Message
    DustyShinigami polycounter lvl 4

    Sorry to resurrect an older thread, but I'm currently encountering this problem again. I've no idea what the heck I was talking about by setting the Reflectivity from Specular to Metalness . o_O That makes no difference. I've gone back over the video that was posted above too. Even just importing the model in, without setting up a Bake Project, just brings in basic white materials, rather than the ID materials I set up in Max. Even with Import Materials ticked, under Import Options, and then reloading the mesh, it makes no difference. :-\

  • DustyShinigami
    Offline / Send Message
    DustyShinigami polycounter lvl 4

    Ah-ha! Got it. I'll leave this here for future reference. It looks like, by default, the option to import them in is unchecked. Going to Edit > Preferences > Content and then checking Import Materials With Models fixes the problem. :)

  • Mikamoto
    Offline / Send Message
    Mikamoto polycounter lvl 3

    Just come here to thank you a lot for your guide. I've got this problem too.

Sign In or Register to comment.