Home Marmoset

Low poly fire creation

Hello guys :) !
I hope you are fine and have a lot of cool projects.
I'm currently working on this piece and I am stuck in the creation of low poly fire to look good in marmoset. :'(
I tried flat planes and painting yellow orange and red flames but it doesn't look good.
It's way too flat.


This is based on the concept art of Dmitri Shulepko. here a link to his original 2D artwork : https://www.artstation.com/artwork/3oP6OB (I asked him if I could make his artwork in 3D and he said yes).
I pushed the lights under the caldron extremely high and also put some emissive map for the green water and the flames (and some opacity map too).

Please can you give me some advise in order to improve my flames ? 


Also I have an other small issue, maybe you will have a hint for me:

In marmoset I want to activate the Global Illumination but there is a weird green light under the caldron when I activate "Specular".
It's like the emissive map for the green water was shining through the metal that I cap (just under the water to be sure that It wasn't the issue here). And instead of a black shadow that I should have (AO should also be black) I've got a green light which is not wright.
Maybe you have an idea to mask that ?

Replies

  • Eric Chadwick
    Moving this from Technical Talk to the Marmoset section.
  • Obscura
    Offline / Send Message
    Obscura grand marshal polycounter
    Try an unlit shader with translucent or additive blend mode instead of dithered alpha test. Also use higher opacity value and a lot of emissive.
  • pixelion8
    Obscura said:
    Try an unlit shader with translucent or additive blend mode instead of dithered alpha test. Also use higher opacity value and a lot of emissive.
    Thanks ! yes it's much better. Additive blend mode works great:

    I was playing with the extra custom part off my shader and I found the fresnel script.
    After playing with it I made that:

    Looks interesting too !
    Which one do you prefer ? 

    Also I still have the issue with my green light under the caldron... I don't get why is that appenning.
    And my render gives me broken pixels at the bottom of my picture (near the rocks). (even with a size of 4k 400x)  :# [EDIT] I removed mip correction in the render settings and it is better. (less broken pixels).
    Do you have a hint on why I have still an issue with this green light under the caldron ?
  • EarthQuake
    Global Illumination works by creating a simplified, voxelized version of the scene (think Minecraft blocks, you can see the result of this by checking Show Voxels). If your cauldron mesh has relatively thin walls, there could be gaps in the voxelized version which will cause light leaking. You can try reducing the Voxel Scene Fit value until it's as small as possible while still covering the cauldron, this may help to focus more of the voxel resolution.

    Alternative you could try making the walls of the cauldron thicker, that may help too.
  • pixelion8
    Ok, thank you for your explenations.
    I tried to cap the holes but I did not tried to thickened them.
    I had to finish and move on to the next piece so here is my final result. In the futur i'll definetly put to good use your informations.

    and my first video:

    thanks !
Sign In or Register to comment.