Maya to Unity animation not working

Hello. I export skeleton with baked animation and in unity it is absolutely still. I get the message on the pic.



It connects to the character and I guess the file is ok but no matter what I do Unity is not showing any animation in this prefab -- the character is not moving at all. Does anybody have any idea what it could be?

Replies

  • danr
    Offline / Send Message
    danr interpolator
    Have you made sure you’ve checked Import Animation in the fbx import settings
  • Hito
    Offline / Send Message
    Hito interpolator
    Animation should be visible in preview window after drag/drop character into it, as long as their skeleton hierarchy is same

    Drag/drop the animation clip onto a character in scene panel and enter playmode to see it play

    or create a timeline and assign the character to an animation track and insert the animation clip to the track, scrub timeline to see animation, no need to enter playmode.

  • Ruslana_Volichenko
    danr said:
    Have you made sure you’ve checked Import Animation in the fbx import settings
    yep. So the problem was I did not choose type of animation in unity and I have to import mesh with bones. Maybe -- because I was trying many things at once and after something it worked
  • Ruslana_Volichenko
    Hito said:
    Animation should be visible in preview window after drag/drop character into it, as long as their skeleton hierarchy is same

    Drag/drop the animation clip onto a character in scene panel and enter playmode to see it play

    or create a timeline and assign the character to an animation track and insert the animation clip to the track, scrub timeline to see animation, no need to enter playmode.

    Yes) I know. It works now. Anyway thanks for your thoughts
Sign In or Register to comment.