Home Technical Talk

3DS Max Crazy Normals

interpolator
Offline / Send Message
Axi5 interpolator
I'm not 100% if this is caused by normals,
I'm using 3ds Max 2011 and I have some really crazy problems going on.

I started with this low poly mesh:
c1b68fe049348026204495367b0e8951.png

I UV'd it in Headus UV layout
I worked on the high poly in ZBrush but this particular model didn't end up there, I intended to bake down.

I decided that I didn't need most of the little grooves and indentations and that a normal map would be sufficient so I converted to editable poly and tried to remove them, when I started removing them I got this result:
eacdce07da100ac48e9d8ee6d64dec94.png

It looks like the smoothing groups are different but that entire row plus the rows above and below are set to 4.

The weirder part is when I undo this it gives me an even crazier result:

a2d210e3fbb25970f164e793843c647c.png


I'm honestly not sure what's causing this, things I've tried:
Resetting XForms,
Checking Polygon Smoothing Groups (several times),
Putting a Normal modifier on and unifying/flipping and checking etc.

I've also tried resetting UV's and even an older version of my model before UVing in case Headus was the culprit.

Furthermore the OBJ exports with this problem as well so it doesn't seem to be Max specific it might be my geometry.

However, my friend who had access to this model managed to do the same thing I was attempting without any issues, so could my Max version be bugged?

If not does anyone have any explanations for why this might be happening?

EDIT:
Tried in Max 2014 student too, same problem so I assume it's my geo although with the amount of problems I've been having I'm starting to warm to the idea of starting again, it's currently halting me at the moment :/

Replies

  • Mark Dygert
    I've had this happen with models imported/exported as obj in max. One thing that fixes it for me is to open the UV editor and weld all the verts with a microscopic threshold.
    It's not that they are unwelded but that it causes max to rewrite a portion of the file that isn't being updated. Sometimes it clears it up right away sometimes you have to export as obj and import again.

    I think the problem comes from the OBJ exporter so if you can, avoid using it, stick to fbx or some other format =/
  • Axi5
    Offline / Send Message
    Axi5 interpolator
    I've had this happen with models imported/exported as obj in max. One thing that fixes it for me is to open the UV editor and weld all the verts with a microscopic threshold.
    It's not that they are unwelded but that it causes max to rewrite a portion of the file that isn't being updated. Sometimes it clears it up right away sometimes you have to export as obj and import again.

    I think the problem comes from the OBJ exporter so if you can, avoid using it, stick to fbx or some other format =/

    Thanks so much I'm trying this now!
    My friend said the same to me but in my past I've only experienced bugs with FBX and not so many with OBJ, I'm just going to have to experiment to see where each works best it seems :/

    Is there another weld option in Max's Uv editor? The only one I know of is Weld Selected which unfortunately turns the whole thing into a garbled mess with no threshold options.

    Or do I weld them on the model behind while the uv editor is open? should I weld just my shells or just ctrl + a and weld that way?
  • Ruz
    Offline / Send Message
    Ruz ngon master
    I thought by the title that it was a new program called 'crazy normals' , bit like crazy bump:)
  • Axi5
    Offline / Send Message
    Axi5 interpolator
    Ruz wrote: »
    I thought by the title that it was a new program called 'crazy normals' , bit like crazy bump:)

    Aha sorry about that I really didn't know what else to call it, I assumed it was a normal problem but I haven't seen any normals this catastrophic before haha
  • poopipe
    Offline / Send Message
    poopipe veteran polycounter
    turn to mesh modifer followed by dicking around in the edit normal modifer and converting back to poly will usually give it enough of a kick to start responding to your requests.

    basically its split and locked all your vertex normals - what i like to call maya simulation mode - you just need to force them back to something you can edit.
  • Axi5
    Offline / Send Message
    Axi5 interpolator
    poopipe wrote: »
    turn to mesh modifer followed by dicking around in the edit normal modifer and converting back to poly will usually give it enough of a kick to start responding to your requests.

    basically its split and locked all your vertex normals - what i like to call maya simulation mode - you just need to force them back to something you can edit.

    definitely onto something there, the troublesome polys are showing blue normals not green.

    cc6e70798d21d483628925efff4dab38.png

    Unfortunately I don't know much about the edit normals modifier and don't know how to change it.

    EDIT:
    Didn't notice this before but I seem to have normals pointing upwards, all around here, not sure I'd like going around changing all these normals but its all I can do for now, thanks.

    I hope someone can help me with a quicker fix though but it'll do for now (:
  • MaD
    Offline / Send Message
    MaD polycounter lvl 7
    Looks like your normals got a bit stuck. Happens a lot, certainly when using custom normals. Just add a edit normal modifier. select all ,reset normals, collapse and add smoothing groups again. Should work. Anyway the green normals lines indicate explicit normals.

    check out: 3ds max help edit normals for more info
  • Axi5
    Offline / Send Message
    Axi5 interpolator
    MaD wrote: »
    Looks like your normals got a bit stuck. Happens a lot, certainly when using custom normals. Just add a edit normal modifier. select all ,reset normals, collapse and add smoothing groups again. Should work. Anyway the green normals lines indicate explicit normals.

    check out: 3ds max help edit normals for more info

    Thanks for the help man (:

    A whole new side of normals for me to explore haha :D
  • Mark Dygert
    They don't make the weld threshold easy to find, it's inside the UVW window > Options > Preferences > Weld Threshold.

    This covers it in greater detail:
    [ame=" UVs in Zbrush 4.0: How to fix them! - YouTube[/ame]
  • Axi5
    Offline / Send Message
    Axi5 interpolator
    They don't make the weld threshold easy to find, it's inside the UVW window > Options > Preferences > Weld Threshold.

    This covers it in greater detail:
    Broken UVs in Zbrush 4.0: How to fix them! - YouTube

    Thanks for the heads up!
    Definitely useful in case I come across a similar problem, in this case though poopipe and MaD were spot on about the edit normals :D
Sign In or Register to comment.