3ds Max not showing vertices

  • Offline / Send Message
  • Joined
  • 46 Topics
  • 318 Replies
NEVERMIND! Reset Max, Open scene = DONE.

Actually I am curious to know what causes the problem mentioned below

Now here's a funny thing.. As of right now, Max has ceased to display vertices. Well, actually I see they're there, but only 1 pixel large. When I modify the size of the verts in my preferences (usually they're at 3) they display correctly once I hit ok, but as soon as I move in the viewport they disappear. Another weird thing is the vert colors changed briefly as well, they became much darker. This has happened to me before and somehow I fixed or it righted itself, but can't remember how.
Another note, I've got a large amount of DX materials in my scene which I am now consolidating. Max 08 BTW.

Any suggestions?

Replies

  • pior
    • Online / Send Message
    • Joined
    • 122 Topics
    • 7.1K Replies
    pior polycounter, lvl. 13
    Happens to me all the time, iirc there is one specific stack modifier combination causing this. Will try to dig it up!
  • sir-knight
    • Offline / Send Message
    • Joined
    • 36 Topics
    • 596 Replies
    I found if the computer goes into sleep mode or screen saver while the max window is open verts can disappear, and end up showing only wireframes even though you have smooth/highlights on.
  • thomasp
    • Offline / Send Message
    • Joined
    • 47 Topics
    • 2K Replies
    thomasp card carrying polycounter
    my box at work does that as well. looks like geforce graphics driver problem tho since it works fine at home with a quadro... likewise can't recall having the vertices disappear on the home setup but have encountered it a few times at work.
  • sir-knight
    • Offline / Send Message
    • Joined
    • 36 Topics
    • 596 Replies
    I had a quadro fx card on my old work machine that did it as well, on a geforce8200 now I think, does the same thing.
  • FAT_CAP
    • Online / Send Message
    • Joined
    • 51 Topics
    • 805 Replies
    FAT_CAP polycounter
    Yeah this happens to me when the screensaver has kicked in - very annoying

    I found that instead of a resave, shutdown and restart if you go into the Customize> Preferences> Viewports tab and next to Show Vertices as Dots there is a size spinner - changing this up or down will make the verts display properly on OK-ing this :)
  • Tumerboy
    • Offline / Send Message
    • Joined
    • 46 Topics
    • 2.7K Replies
    I have no idea what causes it, but I know how to fix it (most of the time)

    Select your object, go into Vertex mode, and hit "unhide all" like you would with polies. WHY you can hide vertices, I don't understand.
  • jeremy price
    • Offline / Send Message
    • Joined
    • 7 Topics
    • 111 Replies
    a band aid fix, but by converting the mesh to editable poly again the verts should show up. No idea what causes it either.
  • MoP
    • Offline / Send Message
    • Joined
    • 135 Topics
    • 11.5K Replies
    It happens to me sometimes, it seems like it's resetting the vertex draw size (default is 4 pixels or something), it seems to go back to 1px because I can still sometimes see the verts glittering in and out of view under the wireframe.

    The way I always seem to be able to fix this is by selecting all vertices then go to Scale mode, the verts draw proper size after that, no restart/reopen needed.
  • steady
    • Offline / Send Message
    • Joined
    • 44 Topics
    • 994 Replies
    haha thanks for these tips, i've encountered this problem a few times!
  • Szark
    • Offline / Send Message
    • Joined
    • 9 Topics
    • 155 Replies
    This happens quite often to me, the way I fix it is maximising one of the orthographic views and then the verts come back.
  • gd77
    • Offline / Send Message
    • Joined
    • 0 Topics
    • 1 Reply
    This is cause when you use direct X driver and not openGL, to fix it just go to , Preferences--> Viewports ---> click on choose drivers botton then enable Redraw scene on windows expose, for big scenes polygons count, disable it or it will be problem when opening the scene or rotating it...
  • hosch
    • Offline / Send Message
    • Joined
    • 1 Topic
    • 7 Replies
    I have not verified what causes this, but the driver makes sense. What I have verified is this is not something (at least in my experience) that is isolated to a specific file or for 3ds Max overall, but rather specific to a certain object. Here is how I have solved this issue in the past (and it happens to me at least a couple times a week) I export the object as an OBJ and then reimport it - merging into a new file does not seem to work for this problem.

    When I have this issue other objects in the same file do not have the issue - just the object I was working on at the time. It is like the object itself gets some sort of curruption and the OBJ export/import cures the problem.

    This occurred for me in both Vista and Windows 7 (which is not yet supported by Autodesk).

    Hope this helps.
  • Mark Dygert
    • Offline / Send Message
    • Joined
    • 237 Topics
    • 14.7K Replies
    I've had verts disapear and they don't show up if I unhide all in vert mode. Normally going down to element mode and doing an unhide all takes care of the problem. Never understood why or how...
  • mLichy
    • Offline / Send Message
    • Joined
    • 29 Topics
    • 1K Replies
    Yeah, I've ran into this too... I would like to know why it happens as well.
  • Shogun3d
    • Offline / Send Message
    • Joined
    • 30 Topics
    • 1.3K Replies
    Shogun3d dedicated polycounter
    Doesn't vertex paint on stack automatically sets vertex hidden mode? I've had this problem occur mostly during vertex painting.
  • Ruz
    • Offline / Send Message
    • Joined
    • 306 Topics
    • 4.7K Replies
    Ruz insane polycounter
    I ahve got so used to this I just don't bother and select where the verts look like they are supposed to be
  • Alberto Rdrgz
    • Offline / Send Message
    • Joined
    • 34 Topics
    • 2.4K Replies
    Alberto Rdrgz card carrying polycounter
    Mop had it right... thats the same thing that happens to me and i have a geforce right now.
  • Jeremy Wright
    • Offline / Send Message
    • Joined
    • 9 Topics
    • 1.2K Replies
    Ruz wrote: »
    I ahve got so used to this I just don't bother and select where the verts look like they are supposed to be

    Same here. I never seemed to have this issue until I started testing out directx viewport shaders.
  • Alberto Rdrgz
    • Offline / Send Message
    • Joined
    • 34 Topics
    • 2.4K Replies
    Alberto Rdrgz card carrying polycounter
    you know what i just figured out..... when ever it hapens to me, right away i start flipping thru the the tools (scale, move, rotate...) till they come back and usually for the most part they come back right away.
  • Lokies
    • Offline / Send Message
    • Joined
    • 0 Topics
    • 2 Replies
    If you have the problem where its just the one object not showing verts you can just create a primitive> convert edit poly> attach your problem object> delete your primitive element. As a side note I suggest being at top level when doing so.
  • TP-Oreilly
    I know this is an old discussion so you all probably know, they may be hiding because you all have "show end result on/off toggle" switched on, if you turn it off the vertices will show.
  • seir
    • Offline / Send Message
    • Joined
    • 19 Topics
    • 96 Replies
    TP-Oreilly wrote: »
    I know this is an old discussion so you all probably know, they may be hiding because you all have "show end result on/off toggle" switched on, if you turn it off the vertices will show.

    Sorry for digging old topic but I tried everything and this one helped me.
  • Quack!
    • Offline / Send Message
    • Joined
    • 12 Topics
    • 1.3K Replies
    Quack! dedicated polycounter
    This happens to me all the time. The solution for me is to always click in an ortho view, then click into perspective view, they come back in the perspective view.


    /old
  • Justin
    • Offline / Send Message
    • Joined
    • 2 Topics
    • 13 Replies
    I've had a problem similar to this but haven't found a way to fix it besides closing and re-opening. But in my case, some verts would show up where they were supposed to, while others would appear in a cluster off in space. Strangely, the verts off in space could not be selected where they appeared, but by clicking position where they should be appearing on the object would still highlight them. Odd.
  • Will Faucher
    • Offline / Send Message
    • Joined
    • 106 Topics
    • 1.6K Replies
    Will Faucher dedicated polycounter
    I just reset x-forms, collapse, and bam. Vertices are back.
  • Racer445
    • Offline / Send Message
    • Joined
    • 27 Topics
    • 1.2K Replies
    so, what graphics card does everyone with this issue have? i'm on ATI (4870) and getting this issue, and i'm thinking it could very well be yet another ATI bug.
  • Will Faucher
    • Offline / Send Message
    • Joined
    • 106 Topics
    • 1.6K Replies
    Will Faucher dedicated polycounter
    You can always simply copy the modifier, delete it, reset xforms, and then paste it back on. This preserves your skin, projection, etc.
  • kurt_hectic
    • Offline / Send Message
    • Joined
    • 20 Topics
    • 234 Replies
    In my case, on ATI raden card I... opened ati panel, disable one monitor, change resolution, change to clone mode ect. and after that back to the standard, dual screen option witch normal resolutions. After that, finally I can see my vertices.
  • Justin
    • Offline / Send Message
    • Joined
    • 2 Topics
    • 13 Replies
    I'm having a similar problem, but I can't even select the vertices by clicking and dragging where they should be. Oddly, I get one vertex that shows up and allows me to select it. I know the other vertices are there because I can select all the faces and then go to vertex mode, but that doesn't help when trying to modify certain vertices. I've tried collapsing stacks, changing vert size, unhide all, closing and re-opening file; all to no avail. Anyone else have a similar issue?

    NO_Verts.jpg
  • Jessica Dinh
    • Offline / Send Message
    • Joined
    • 69 Topics
    • 1.7K Replies
    Jessica Dinh dedicated polycounter
    Perhaps try saving your object and opening it up in a new scene? Try saving it out as a max file first, and if that doesn't work, try obj. maybe?
  • THE 5
    • Offline / Send Message
    • Joined
    • 25 Topics
    • 296 Replies
    For that "normal case" that they went to 1pxl I usualy do 2x Alt+W. (In Max 2010 that is...)
    Maximise Viewport, minimize aggain, or vice versa.

    Also: ATI 5500 HD
  • disanski
    • Offline / Send Message
    • Joined
    • 32 Topics
    • 980 Replies
    disanski polycounter
    Not sure if it is mentioned already but for me it works if I just add edit poly modifiere on top they show up again. I seen this happen on nvidia as well.
  • Phil101
    • Offline / Send Message
    • Joined
    • 16 Topics
    • 97 Replies
    I would have thought a company that charges such crazy prices for its software would have fixed this issues already. Its nothing major but it is still annoying.
  • WarrenM
    • Offline / Send Message
    • Joined
    • 76 Topics
    • 3.9K Replies
    WarrenM veteran polycounter
    Max has a lot of little annoyances that you would think they'd fix ... but they don't. :)
  • piorun
    Sometimes works clicking on "Unhide All" in Edit Poly Vertex mode.
  • Justin Meisse
    • Offline / Send Message
    • Joined
    • 329 Topics
    • 8.5K Replies
    Justin Meisse I love typing
    I was having that issue on one model so I went into customize>preferences>viewports and upped the vertices size by one.
  • SeveredScion
    • Offline / Send Message
    • Joined
    • 2 Topics
    • 54 Replies
    There is another thing that can make the vertices disappear or only display as one pixel--turning on hardware shading in the viewport (I'm using 3ds max 2010). The hotkey to toggle hardware shading on and off is shift+F3. Or right click on the viewport menu in the upper left of the viewport, go to lighting and shadows, then toggle off "enable hardware shading" if it's on. Hopefully this helps some of you.

    Also, sometimes if I hide other sub-objects, it hides vertices as well. So if I'm not seeing verts I also go to faces and element sub-object mode and click "unhide all" under "edit geometry" in the stack.
  • Ruz
    • Offline / Send Message
    • Joined
    • 306 Topics
    • 4.7K Replies
    Ruz insane polycounter
    or you could just click on a different viewport then click back on yours. this fixes it\like what Quack said:)
  • mauzr
    • Offline / Send Message
    • Joined
    • 0 Topics
    • 2 Replies
  • Gauranga
    • Offline / Send Message
    • Joined
    • 0 Topics
    • 1 Reply
    No no no! The cause of hidden vertexes is accidental pressing of shortcut Alt+I while you are in subobject vertex level. The solution is simple: go to that level again and just press Alt+U. It is max's feature. When you are on subobj level you can hide (and show) unselected vertexes/faces/objects. Have a nice day friends!
  • ezili
    • Offline / Send Message
    • Joined
    • 0 Topics
    • 2 Replies
    Tumerboy, it works thanks
  • sogun
    • Offline / Send Message
    • Joined
    • 3 Topics
    • 39 Replies
    sogun vertex
    SOLUTION:

    All right, if anybody can't find the autodesk link or "nothing works", here is how you get the damn vertices showing in Max:

    If you are using and NVIDIA card: (ATI users just try copy/follow/select the features)

    Problem is how NVIDIA translates DirectX features - they are always RE-INVENTING and re-fixing a DirectX display, that worked before perfectly... - and how Max uses them by default.

    Go to NVIDIA Control Panel (right click) find Manage 3D Settings, Program Settings, Add, find and select the appropriate 3DSMAX.EXE

    Go to features:

    Set Aniso filtering 16x or highest

    Set All Antialiasing OFF

    Max pre-render frames: 1

    Single Display Perf. mode (or experiment)

    Texture filtering Aniso OFF

    Negative LOD CLamp

    Texture Filtering High Quality

    Trilinear OFF

    Threaded OFF (or ON experiment)

    Triple buff OFF

    VSYNC OFF


    Start Max: in Viewport Parameters now you can select Show vertices as Dots it works or have it as not so easily visible ticks.

    NVIDIA driver: 320.18 but it should work with all drivers.
  • sogun
    • Offline / Send Message
    • Joined
    • 3 Topics
    • 39 Replies
    Still vertices were appearing and disappearing, seemingly on a whim, then I discovered that pressing my Maximize Viewport toggle shortcut, all vertices reappeared. :)

    Since then I'm using this fix coupled with above config.
  • Mrfred
    • Offline / Send Message
    • Joined
    • 12 Topics
    • 96 Replies
    Happens to me everyday but I can fix it easily...
    Press windows key + d minimise max
    Then windows key + L lock session then unlock

    Tadaaa verts are back... Silly max and his jerky viewport

    Sogun: ill try your olution next time it happens :)
  • Mrfred
    • Offline / Send Message
    • Joined
    • 12 Topics
    • 96 Replies
    edit: alt+w 2times fix the issue as well :P thanks sogun
  • elenasakura
    • Offline / Send Message
    • Joined
    • 0 Topics
    • 2 Replies
    I had a problem with vertices not showing up whenever I tried to go into vertex mode on an editable poly. It would show on other objects, but not on this one. So I exported the object as a .obj, imported it back into the project, and then vertices were showing up correctly.
  • rosenand
    • Offline / Send Message
    • Joined
    • 3 Topics
    • 10 Replies
    This thread popped up in google, only Gauranga's solution worked for me, go to vertex mode and press Left Alt + U. Seems to be a feature indeed, not a bug (although I don't recall pressing Alt + I, but I was hiding/unhiding polys).
  • thomasp
    • Offline / Send Message
    • Joined
    • 47 Topics
    • 2K Replies
    thomasp card carrying polycounter
    there's definitely more than one issue being discussed in this thread. hidden vertices on a mesh are one thing and an unwanted side effect of features in max.
    but an entirely different problem and the one that started this thread is that vertices sometimes turn 1-pixel-small, making them hard to see and near impossible to select. i think they may have caught that one in some later release though. haven't seen it in years.

Leave a Comment