Home Unreal Engine
Automatic "Save Draft" has been disabled temporarily. This means comments are not being auto-saved as you type.

Drafts can be manually saved whenever the "Save Draft" button is clicked.

We're chasing down a bug, and we'll let you know when autosave is re-enabled. Thanks!

How to fix UDIMs in Unreal Engine?

polycounter lvl 2
Offline / Send Message
K_Art3D polycounter lvl 2
How to fix UDIMs in Unreal Engine?

Replies

  • Obscura
    Offline / Send Message
    Obscura grand marshal polycounter
    What dou you mean? What is the error?
  • K_Art3D
    Offline / Send Message
    K_Art3D polycounter lvl 2
    Hey Thanks for responding.
    So the lighting map does not match with the actual texture map. Because I have 5 different maps in total this is one of them which it shows that its on the third UV box horizontally. My problem is Unreal does not recognize the 5 Maps next to each other the way Substance Painter or Maya does when you turn on the (create a texture set per UDIM tile).
  • Obscura
    Offline / Send Message
    Obscura grand marshal polycounter
    You mean it only applies the first texture? Can you be a little bit more specific please? Currently I can only shoot in the dark and point on possible things which we could heavily narrow down by accurately describing whats happening, and what you are expecting to happen.
  • K_Art3D
    Offline / Send Message
    K_Art3D polycounter lvl 2
    So this is what I have inside Maya I want my UV channels in Unreal to look the same as this map but for some reason Unreal doesn't recognize it, so it shows that its there, but as you can see on the previews picture it shows that its red. usually the Channel 0 should be same UV map as the textures and the Channel 1 is the one that unreal makes. Is there a way to fix the Channel 0 in unreal so the red map moves inside the Channel box?
  • Obscura
    Offline / Send Message
    Obscura grand marshal polycounter
    This should work by default unless all tiles are on a separate uv set. Red only means its outside of 0-1 space but thats it. No negative effect from that. 

    Like I said it should import it as it is and should make no change to the uvs whatsoever. 

    Now I'm looking at your first picture and the mesh there and on your last pic are different. Seems like you imported it in parts maybe? And then it makes sense that it only shows the relevant uvs to that mesh. There is a checkbox in the import dialogue called "combine meshes". If you indeed have them in parts inside Unreal, make new import using that option and check if its fixed then. If you are still getting issues after that, let me know.
Sign In or Register to comment.