Home Unreal Engine

Unreal Developer Kit - MASTER THREAD

1212224262739

Replies

  • Oniram
    Offline / Send Message
    Oniram polycounter lvl 14
    @sampson: to render out of a camera you'll want to use whats called Benchmark. its used mostly to render out a sequence at a different framerate (i.e. if ur pc cant handle the camera matinee flythrough for a capture video). here's a pretty descriptive tut on how to do it.

    http://forums.mp-gaming.com/thread-11125.html

    hope it helps.


    example of this... [ame]
    that video was rendered at around 30 fps but the user saw it at .4 fps as it was rendering.
  • sampson
    Offline / Send Message
    sampson polycounter lvl 9
    i think i've asked this somewhere in the forums somewhere but can't find my post..

    does anyone know how to reduce the speed of the player, in my level the height is okay, but he walks around WAYY to fast.
  • Oniram
    Offline / Send Message
    Oniram polycounter lvl 14
    as for actually slowing down the animation, im still trying to get my head around anim trees.. but for speed its just.

    GroundSpeed = x; (x being your desired speed). ive got mine in a function calling between sprinting speed and running speed.. so it looks like this.

    exec function Walk()
    {

    CamOffset = vect(8,15,-20);

    }

    exec function Run()
    {
    GroundSpeed = 1000.0000;
    CamOffset = vect(15,0,0);


    }
  • 3DRyan
    Offline / Send Message
    3DRyan polycounter lvl 8
    VERY quick question. The LOD of my shadows keep popping in and out as I move away and towards objects. Anyone know how to get rid of this?
  • SunSetter
    Offline / Send Message
    SunSetter polycounter lvl 9
    Hi, I believe that is not the first time when someone is getting this king of error(I'm new to UDk, btw, great tool) but I'm suppose to show someone an asset inside UDK and my texture look crappy...
    here's a screen :
    why.jpg
    does anyone know why this is happening?!

    thanks



    ok, so...I found the problem, I was using Ati card with some older drivers. After instaling the latest ones the problem disappeared.
  • Ixion
    Hi I'm having problems with an unwanted rimlight on an object. It's using multiple materials with multiple uv's, so it might have something to do with the rendering. It might also be some new feature for the new UDK I have no idea about but I can't find a way to get rid of it. Thanks.

    2d8ghf6.jpg
  • cholden
    Offline / Send Message
    cholden polycounter lvl 13
    that's not a rim light, it's SSAO, a default thing. You can disable it. Look up how if you want to know where.
  • Ixion
    I looked around a bit and couldn't find anything on changing it or disabling, nothing on the web, I checked the mesh properties, world properties, and the one light properties, ill keep trying though, might just have to get previous udk version.
  • Lamont
    Offline / Send Message
    Lamont polycounter lvl 13
    Ixion wrote: »
    I looked around a bit and couldn't find anything on changing it or disabling, nothing on the web, I checked the mesh properties, world properties, and the one light properties, ill keep trying though, might just have to get previous udk version.
    Hint: It's a PPE.
  • Ixion
    Thanks guys, appreciate it. Was in default post processing effects in world info, second check mark in ambient occlusion.
  • Momo
    I keep getting a lighting seam where my static meshes connect. I looked at UDN and found this link http://udn.epicgames.com/Three/LightingReference.html. It says to change the number of subdivisions and enable bUseSubDivisions to fix the issue. But the option doesn't exist... Any ideas? Second UV set is there, tried fiddling with resolution but it doesn't make a difference.

    seam.jpg
  • Quillisia
    @Momo: Do you still get the problem with highest lighting setting? I get the same problem but the issue almost disappears with production settings
  • Rurouni Strife
    Offline / Send Message
    Rurouni Strife polycounter lvl 10
    New UDK Version! http://udk.com/news-beta-aug2010 Has some nice updates and changes. Get it while it's hot!
  • Mypeople
    thanks for the heads up rurouni.
  • fearian
    Offline / Send Message
    fearian Polycount Sponsor
    that motion blur looks sexy!
  • 3DRyan
    Offline / Send Message
    3DRyan polycounter lvl 8
  • Momo
    Quillisia wrote: »
    @Momo: Do you still get the problem with highest lighting setting? I get the same problem but the issue almost disappears with production settings

    Hey sorry for the late reply, haven't had a chance to mess with it recently. I tried just changing the lighting settings to production but it doesn't look like it had any effect.

    Here is the UDK example I was referring to. Although I can't find the option for using subdivisions anywhere.

    subdivisionseams.jpg

    primitivelightingoptions.jpg
  • SanderDL
    Offline / Send Message
    SanderDL polycounter lvl 7
    @Momo:

    Make sure both surfaces have the same smoothing group. I get that sort of errors all the time.

    If that doesn't do it, it could also be the UVs of the lightmap being too close to the border.
  • Momo
    SanderDL wrote: »
    @Momo:

    Make sure both surfaces have the same smoothing group. I get that sort of errors all the time.

    If that doesn't do it, it could also be the UVs of the lightmap being too close to the border.

    Tried re-rendering out the normal map multiple ways and with various combination's of smoothing groups but no change. Lightmap UV's should be fine. All individual space and plenty of buffer between everything.

    I'm assuming its not the normal map. As I totally removed the normal map from unreal and I'm still getting a seam where the static meshes connect. Gonna re-look at the lightmaps again but I'm running out of ideas.
  • Ben Apuna
    Momo, it looks like you are using vertex lighting rather than actual pixel based light maps as your static mesh has it's bOverrideLightmapResolution checked on and it's OverriddenLightmapResolution set to 0. Lightmap resolution set to 0 in Unreal means use vertex based light maps.

    You should un-check bOverrideLightmapResolution, then bring up your static mesh in the Content Browser and change it's Light Map Resolution to something like 16 or 32, also make sure your Light Map Coordinate Index is properly set.

    Finally re-build your lighting.

    If you still end up with a seam between the meshes you'll need to change the Indirect Normal Influence Boost setting from 0.3 to 0.

    View -> World Properties -> Lightmass -> Lightmass Settings -> Indirect Normal Influence Boost

    I hope that helps.
  • crasong
    Offline / Send Message
    crasong polycounter lvl 11
    I dont have my workfiles handy to post screengrabs, and this might be a noob question.

    So I've been importing my static meshes into the level, and initially the shadows that they cast on the floor are correct, with the approprite details in the shadows even. But once i hit build all, their shadows all become wrong, like, wrong shape and size wrong. Any reason why this is happening?
  • Momo
    Ben Apuna wrote: »
    Momo, it looks like you are using vertex lighting rather than actual pixel based light maps as your static mesh has it's bOverrideLightmapResolution checked on and it's OverriddenLightmapResolution set to 0. Lightmap resolution set to 0 in Unreal means use vertex based light maps.

    You should un-check bOverrideLightmapResolution, then bring up your static mesh in the Content Browser and change it's Light Map Resolution to something like 16 or 32, also make sure your Light Map Coordinate Index is properly set.

    Finally re-build your lighting.

    If you still end up with a seam between the meshes you'll need to change the Indirect Normal Influence Boost setting from 0.3 to 0.

    View -> World Properties -> Lightmass -> Lightmass Settings -> Indirect Normal Influence Boost

    I hope that helps.

    Sorry for the confusion. The picture I posted was from the UDN website. And not one of my own static mesh. The reason I posted it was because there was an article on UDN that said to enable "bUseSubDivisions" But that option doesn't show up for me like it does in the picture posted.

    I checked the options you mentioned anyways. "Override Light Map Res" is disabled. I messed around with the Normal Influence Boost but it had no effect.

    I have a feeling I'm overlooking something very basic as I don't see why this should be such an issue.
    So I've been importing my static meshes into the level, and initially the shadows that they cast on the floor are correct, with the approprite details in the shadows even. But once i hit build all, their shadows all become wrong, like, wrong shape and size wrong. Any reason why this is happening?

    Do you have your lightmap UV's set up so they all have individual space and no overlapping?
  • crasong
    Offline / Send Message
    crasong polycounter lvl 11
    Hey Momo, the model was done by another artist, he did create a seperate channel for the lightmap with unique layout, and when i tested just this same house asset in a new level the shadows it cast were correct, meaning something in the setup of this level is causing it.

    Here's the before when i first place it into the level, the shadow is seemingly correct, with the shape and the direction based off the light.

    beforep.png



    And the after when I hit build all. I'd also like to note that even the direction is wrong. I have only one dominant directional and one skylight in this level so far.


    afterw.png
  • JordanW
    Offline / Send Message
    JordanW sublime tool
    looks like lightmap res is way too low
  • crasong
    Offline / Send Message
    crasong polycounter lvl 11
    Hey JordanW, I think you maybe right. After importing the house itself to a simple scene with the same two light setup, the shadows cast are correct. I can only imagine there's something wrong with the terrain settings, but I can't imagine what or where to set the lightmap resolution for it.

    housetest.png
  • Froyok
    Offline / Send Message
    Froyok Polycount Sponsor
    It's just the lightmap of the terrain who are wrong. Just override it, don't let the UDK set up itself this setting.
  • crasong
    Offline / Send Message
    crasong polycounter lvl 11
    Solved it after realizing I had to tick the override box in order to change the resolution. Thx for the help guys!
  • omid3098
    Hi. is there any place to download a light weight version of UDK?
    latest version is almost 700mb with all sample modes and textures.
    some times before I heard about a light weight version in UDK website. but now I can not find that..
  • Lamont
    Offline / Send Message
    Lamont polycounter lvl 13
    omid3098 wrote: »
    Hi. is there any place to download a light weight version of UDK?
    latest version is almost 700mb with all sample modes and textures.
    some times before I heard about a light weight version in UDK website. but now I can not find that..
    People made those themselves. Someone might have posted it somewhere.
  • Gilgamesh
    Offline / Send Message
    Gilgamesh polycounter lvl 12
    Even lightweight versions usually come in around 450-500 mb barebones, so really just download the entire thing :P
  • omid3098
    downloading ~700mb will tooks almost 1-2 days with my low connection speed!
    any way..
    thank you guys.. :)
  • Wombatinahat
    Hey guys.

    Wonder if anyone can help. I have a fan built into a wall which is casting a shadow on the floor inside the building. The fan is an animated skeletal mesh and I want the shadows to move round on the floor at the oposite side of the room. At the minute all is working fine as long as both the fan and floor shadow are in the frame, as soon as I stop looking at the fan the shadow stops moving. I assume this is something to do with the fan being loaded out of memory to save on resources. I'm hoping theres something i can just tick somewhere to keep the fan moving regardless of where its in view at the time.

    Anyone know how to solve this?
  • JordanW
    Offline / Send Message
    JordanW sublime tool
    make sure the fan has a phys asset
  • Wombatinahat
    it has a phys asset, but I found the "Update skel when not rendered" button, seemed to do the job for me :) cheers for the help
  • PogoP
    Offline / Send Message
    PogoP polycounter lvl 10
    Got a question for ya fellas!

    I'm working on a scene and I want to tighten up the blending between these two textures on my terrain (not a static mesh). Is it possible to do this with terrain materials? I know it is with vertex blending but I'm not sure if it's different with terrain.

    terrainmat_question.jpg
  • AlecMoody
    Offline / Send Message
    AlecMoody ngon master
    Anyone know if a September UDK build is planned?
  • Mypeople
    I built all these rock meshes, is there a way to ...paint the rocks onto my terrain quickly instead of S clicking everywhere i want a rock to go?

    In modo there is this option, its just Mesh paint. in udk mesh paint afk is to paing colors? anyone know if something like this exists? much appreciated as always.
  • Mypeople
    @PogoP

    wouldn't your terrain have to be denser for that to happen? you'd just need more polygons i'd think.
  • A. Rabbit
    Offline / Send Message
    A. Rabbit polycounter lvl 10
    @PogoP

    You could use a super mask, it's a very nice way to pack in loads of terrain textures:
    http://udn.epicgames.com/Three/TerrainAdvancedTextures.html
  • Mypeople
    I have a car inside my unreal environment. Is there a way to make the car not bake in scene lighting? i want to move the car around and it cast real time shadows, and not bake those shadows into my environment. anyone know how i'd do this?
  • cholden
    Offline / Send Message
    cholden polycounter lvl 13
    If you double click the static mesh (or select and F4) to bring up properties...
    StaticMeshActor > Static Mesh Component > Lighting > uncheck Cast Shadow.
    This will cause shadows to not be baked.

    Since the car is more of a dynamic object, you could just spawn it into position and never have to worry about it baking or adding to your compile time. Just spawn it on level load with kismet.
  • PogoP
    Offline / Send Message
    PogoP polycounter lvl 10
    Super mask idea sounds great, but how do I go about creating one that will accurately reflect my map? I could make a mask but not have a clue if it is going to overlay on my terrain well..
  • Mypeople
    I tabbed out of udk to look at something online, came back and i got this distorted...red vinette thing happening? anyone know what is going on and how i turn this off? really fonfused

    9-19-2010%209-32-28%20PM.png
  • Mypeople
    I also have a Saving question.

    I save packages here?
    C:\UDK\UDK-2010-06\UDKGame\Content

    and i save my scene files?
    C:\Users\KELE\Scenes\

    as an example. is this ok?
  • moose
    Offline / Send Message
    moose Polycount Sponsor
    myPeople: that looks like the UT damage indicator, check your post process chain and see if there is a material node the PP chain drawing it. definitely odd for it to just turn on :o

    With saving, I would recommend:

    - save content in UDKGame/Content/YourStuff/, tho Users may be more efficient if you're updating UDK a lot, so you don't have to duplicate packages, or potentially lose packages/maps! Saving outside of UDKGame can sometimes cause loading errors that are generally harmless.
    - save art source elsewhere, in a unified location (C: \Art)
  • Mypeople
    Thanks moose, really helpful, answered all my questions. thanks again. great thread
  • Mypeople
    Is it possible to have the fog not effect the skydomes? i dont know how else to show this problem i'm having besides showing a pic.

    Untitled-12.jpg

    My sky is clear how i want it, but i also want that amount of fog, but then the sky is no longer clear. i was thinking like...a mask or something for the fog, to only effect the objects i want it to maybe? complicated question, sorry, i just hope someone knows how to do this.
  • Momo
    Currently trying to render to texture to create a cube map for my environment. All seemed to work out fine but that the cube map is rotated 90 degrees to the left. This causing all my surface reflections to display sideways.

    Is there a way to rotate the cube map? The reflection shows up fine on the actual screen capture actor but gets rendered to the cube map differently than I would like. Any ideas?
  • mbullister
    Offline / Send Message
    mbullister polycounter lvl 14
    Momo wrote: »
    Currently trying to render to texture to create a cube map for my environment. All seemed to work out fine but that the cube map is rotated 90 degrees to the left. This causing all my surface reflections to display sideways.
    ...


    Quick check: are you running the reflection vector through a transform node before plugging it into the uvs?
  • Momo
    Quick check: are you running the reflection vector through a transform node before plugging it into the uvs?

    I was not. I fiddled with the tranform nodes and finally got what I wanted. I just assumed it would have been easier to change the way it was rendered out. Its appears to be working now. Thanks for the help.

    I'm not quite sure if a cube map is what I need for the floor section though. I have it applied to some glass railing and it seems fine. But on the floor its very noticeable it doesn't line up.

    I've messed around with a bunch of the other render to texture and reflection actors but am not happy with the results. I'm looking for something similar to the results in the bottom image. When I render the bottom image out however, it won't let me apply it to a material with a reflection node.

    Is there a way to get the same effect as the bottom image without using real time reflections?

    ReflectionJunk.jpg
1212224262739
Sign In or Register to comment.