Home Technical Talk

windows 7 wacom/tablet issues

hey guys,

i've looked through all the old threads on this subject and wasn't sure if i should necro an old one or start a new one...in any case, i'm about to rip my hair out so any help would greatly appreciated.

i've recently upgraded my OS to windows 7 home premium and every time i run 3ds Max, i get that little circular splash around my pen cursor and, more importantly, there's a constant lag when i try to use my wacom to rotate the viewport (along with the little "alt", "alt + shift" notifications below my cursor informing me which mod buttons i'm pressing), etc... i use my wacom for everything when i model, etc, so this is pretty much killing my ability to work comfortably.

i have tried turning off all the options in the windows 7 pen and tablet control panel.

i've disabled the Tablet PC Input Service (Computer Management --> Services...) and set it to never re-enable.

i do not have gpedit.msc on my computer (because windows 7 home premium does not include it) so i can't "turn off pen feedback" using that tool.

i've manually edited registry keys to disable UIfeedbackmode, Splash, and (in desperation) a few other random keys that seemed related...
I've done every kind of google search i can think of on the subject...I'm usually pretty good at figuring this kind of stuff out...but i'm pretty discouraged at this point.

thanks so much for any advice.

Replies

  • PredatorGSR
    Offline / Send Message
    PredatorGSR polycounter lvl 11
    This sounds like the same thing that all the other threads talk about. I assume the fix is the same. It worked for me to delete the splash and I did it yesterday.

    Go to Control Panel > Programs & Features. On the left, click on "Turn Windows features on or off. Uncheck "Tablet PC Components" and click OK. Reboot the computer, and it should fix the issue.
  • silversteez
    hey, thanks very much for the reply...

    i forgot to mention in my OP that i did that too. just double checked and it is still unchecked.

    this is why this whole thing is so strange...i mean, i've turned off/disabled just about every tablet pc related thing there is.

    my temporary solution is to go into my wacom settings and put my tablet into "mouse mode" which isn't fun either, but at least i can work for now.

    very frustrating...
  • r_fletch_r
    Offline / Send Message
    r_fletch_r polycounter lvl 9
    to diable the ring:
    under 'pen actions' select 'press and hold' select settings. uncheck 'enable press and hold for right clicking'

    to re enable right clicking:
    if your right click isnt working go into 'pen and touch' in the control panel and make sure 'use pen button as right click equivilent is enabled'

    PAIN IN THE ASS

    I had to use the group policy editor to get rid of the modifier key prompts. you will have to do these with regedit. id post on the wacom forums. someone must have worked that one out
  • NZA
    Offline / Send Message
    NZA polycounter lvl 9
    I had the same thing but managed to get rid of this using the method described above. I did notice though that when I ran certain programs it would come back untill I closed down said program. If I was in outlook (latest version), for example, sometimes the symptons would return untill outlook was killed. Also the same thing would happen with microsoft office communicator. So if you are still having trouble try killing any apps that might be running in the background that possibly uses WPF (I think it's something to do with this part of the .NET framework).

    I hope that helps.
  • Spur
    Offline / Send Message
    Spur polycounter lvl 6
    Thats really wild, I've read a lot of people having the same problem. I just upgraded to a new system with windows 7. After plugging in my Wacom I was expecting to have the same issues as everyone else, but nada, no problems at all.
  • silversteez
    that's exactly what's happening NZA. i don't have any issues until i run 3ds Max--then, all of a sudden, the splash graphic, lag etc all comes back.

    then i tab into zbrush and it goes away. photoshop works perfectly, as well.

    pretty weird.

    thanks for the tip...i'll check up on the WPF thing.
  • Divine Rage
    I've had issues with lagging and such, and I solved them by disabling the 'Tablet PC Input Service' in services.msc. Putting startup type to off or something similar.

    By doing so, however, you no longer have handwriting recognition, gestures, or any sort of similar things. Workarounds for gestures could be altering the settings in your Wacom driver properties ('Wacomtablet.cpl')

    Myself, I've been having issues (after solving this one, and some others) with the preferences for different applications disappearing after a while. Restarts fixes them, but I've got no idea how to change this.

    Now that I've been talking about settings, I'm off to change mine again. :)
Sign In or Register to comment.