Home Technical Talk

Zbrush symmetry help

greentooth
Offline / Send Message
theStoff greentooth
Hey, I was using Zbrush recently to add detail to a character that I exported from Maya. Unfortunately, the symmetry axis isn't in the middle of my character. Does anyone know how to shift the axis of symmetry?

Replies

  • ghost-d
    Offline / Send Message
    ghost-d polycounter lvl 15
    I´m pretty much dealing with the same thing right now. I have the model shifted very slightly from the symmetry axis so some of the details aren´t as sharp on the projected side as it is on the other side. Not that big of a problem for me, it´s just annoying to find out half way done with the sculpting (smart resym wasn´t that much of a solution in this case). But I´d also like to know how to deal with this in future.
  • kendo
    this may have been better over in the technical help section.

    Firstly if you havnt already done so then you need to enable the "local symmetry" option contained on the left hand side of the standard UI.

    If this doesnt work try cloneing the object in question and then adding it as subtool to a polysphere.

    Failing this i recommend you ask over on http://www.zbrushcentral.com/forumdisplay.php?f=2 If they dont know then most likely no one will

    Good luck
  • Psyk0
    Offline / Send Message
    Psyk0 polycounter lvl 16
    If zbrush doesnt cooperate, do it the oldskool way.

    1.If you still have your base mesh, just shift the model onto the origin in maya, re-export to .obj. If not, you can still export your current lowest level and realing in maya.

    2.Go back to zbrush, go down to lowest level, click import, pick the newly exported obj, the mesh should be shifted to correct location, if all went well resume sculpting with all details still intact (of course resym will probably be needed).
  • Anuxinamoon
    Offline / Send Message
    Anuxinamoon polycounter lvl 14
    Usually I find its because your model isnt symmetrical in volume. ie: you have purposefully made one arm larger or something, causing one side to be larger in volume that the other from the centre point.

    The only option for you then is to use local symmetry.
  • theStoff
    Offline / Send Message
    theStoff greentooth
    yeah that's what I did. I tried local symmetry but still doesn't line up.
  • Anuxinamoon
    Offline / Send Message
    Anuxinamoon polycounter lvl 14
    Did you reset Xform and centre the pivot before you exported it as an obj? Can we get a look at your model (screen capture is sufficient)
  • theStoff
    Offline / Send Message
    theStoff greentooth
    Alright, here's a screenshot of my model in maya.

    alienModel_screenshot.jpg
  • Vrav
    Offline / Send Message
    Vrav polycounter lvl 11
    Midline is not perfectly aligned to the horizontal axis; is that the problem? I have no idea how this is done in Maya, but the workflow in Silo for this would be to select a few of the edges that form the mirror-seam midline, set the position of the manipulator as the object's new axis, and then enter 0 for the object's X position... the very slight offset is visible in the top and front ortho views, most apparent if you look at the tail.

    That's my guess.

    edit: though this could be completely wrong if Maya draws its bold line with the left edge at 0, rather than the centre of the line. And for all I know zbrush may not even care about such a tiny offset...
  • Anuxinamoon
    Offline / Send Message
    Anuxinamoon polycounter lvl 14
    Try scaling the guy down and then make a box with a seam down the middle scale it up to fit over your whole model, match the centre line to the middle of your guy then move it towards the back a bit away from your model.

    Then combine and export that into zbrush.

    If that doesn't work, then zbrush is being bloody temperamental again D:
  • ralusek
    Offline / Send Message
    ralusek polycounter lvl 10
    if you want to manually just align it in zbrush, hit "W" to go into transpose move, turn off symmetry, and align it with the axis you're mirroring across (shift to lock your view so you can move it precisely). i don't recommend doing this, but it will solve your problem. you can then do smart resym or mirror and weld and you'll be completely symmetrical. i highly recommend just resetting your object center in maya

    edit: and make sure to hit the "floor button" and turn on your axis if you're aligning it manually with transpose
  • theStoff
    Offline / Send Message
    theStoff greentooth
    hm, I think I get it but i might need to see a screenshot or something if possible. Also, I tried importing into zbrush while with multiple objects. How do you export just one of the objects from zbrush? Is that possible?
  • Anuxinamoon
    Offline / Send Message
    Anuxinamoon polycounter lvl 14
    Exporting one object from zbrush; You will need to separate them into sub groups. An easy way to do that is to go Tools> polygroups> autogroup> Shift+CTRL the parts you want to hide, then go to Tools> Subtools> Split hidden. Then export the subtool you need.

    Did you try the big square box around the character thing yet?
  • ioster
    Try this: Mask off the arms and anything else you don't want moved and in the deformation menu hit smart resym.
  • theStoff
    Offline / Send Message
    theStoff greentooth
    I didn't try the full big box yet, I somehow got it to work though by pressing a mass arrangement of buttons in the symmetry tools. However, I don't recall how I got it to work so I am going to try the box method soon as well. I will try that transpose method as well.
  • PolyHertz
    Offline / Send Message
    PolyHertz hero character
    S-Pivot is what your looking for, it'll re-center your pivot to the center of the visible mesh so the symmetry will work.
Sign In or Register to comment.