Home Technical Talk

3d Max 9 morph targets using Zbrush

I'm trying to use Zbrush 3.0 to create facial morph targets in max 9.

After bringing in my target from Zbrush(exported as an OBJ) and setting up the morpher with the orignal model, when I scrub the morph value, the face on the original model deforms as desired. However it (the whole model) also translates up.

I tried to reset the Xforms on all the models, and reset the pivots of the models to their centers... those dont seem to work.

Any ideas, links, or solutions as to how to fix this problem?


  • Mark Dygert
    How are you resetting X form? Are you using the modifier or the Utilities panel?

    Have you tried attaching all the morphs to a newly created primitive like a box, and then detaching them one at a time? That sometimes helps to clear the crazy data that's hard to wipe.
  • MoP
    Offline / Send Message
    MoP polycounter lvl 18
    Heh, I was getting the same issue as this and never figured it out. The meshes were both straight OBJ imports from ZBrush, pivot points in exactly the same place, XForms reset and everything.

    When I applied a Morpher modifier to the first, and added the second as a target, whenever I morphed towards the 2nd the whole mesh moved up.

    I got around it by just moving the 2nd mesh down and then re-acquiring the target - this seemed to work.

    Definitely weird though, sorry I can't give a solid answer. At least it's not just you :)
  • Neavah
    thanks for the speedy reply! but so far no luck with those suggestions...

    when I move the morph target and re-create the morpher then base model just moves in a different dirrection....
    the box trick, and both Xform resets dont seem to do anything....
  • Eric Chadwick
    You have to Reset Xform after aligning the pivots, did you try this? Morpher won't respect the pivots otherwise.
  • CodeFather
    Offline / Send Message
    CodeFather polycounter lvl 15
    Try to center the pivot points first , apply Xform to both meshes and then use the morpher modifier
  • Mark Dygert
    Have you tried, exporting the original mesh from ZBrush and importing that?
    Have you tried, rexporting everything as another format and importing it back into 3dsmax.
    Have you tried: http://www.scriptspot.com/3ds-max/morphix

    Did you attach all the morphs to the box and then detach them one at a time? Reset Xform I think that worked for me when I had this issue with mudbox. Either that or we redid the morphs from scratch and used paint deform in 3dsmax...
  • Neavah
    So I think I figured this one out (kinda):

    (I'm not sure if I did things differently the becasue I thought I tired this the first many times around, so I'll note all the steps, incase something that seems insignificant was the fix.)

    One at a time :
    I brough in the morph target into max first. I made sure the pivots were at 0,0,0.
    Then I reset the xforms (using the modifier stack)

    Then I hid the mesh, and brought in the another, rise and repeat (note all morph targets are ontop of eachother but hidden)

    lastly I brough in the base mesh, and did the same with the pivots, and resets (everything is ontop of another, all morphs are hidden).

    Applied the morpher, set the targets. It worked.
    I tested it with moving and the morphs and such. It worked (i'm not complaining)

    I'm not sure if them being on top of eachother had something to do with it or the order in which I brought them in... but it worked!! :) thanks again for the feedback!
  • Neavah
    Note: I didnt get a chance to try the script from script spot...
    But everything else I tried (attaching to box, xforms etc.) like I said... maybe I didnt do it right ?! (I'm pretty sure I did, but I was in a slight panic)... But the way mentioned worked.... so maybe it was a panic oversight...???
  • Eric Chadwick
    The order of the tasks is essential, reset xform after setting the pivot, not before. Morpher won't notice any change to the pivot unless you use the Reset Xform utility.
Sign In or Register to comment.