Home Technical Talk

Max 9 - red wireframe, editing UVs

polycounter lvl 14
Offline / Send Message
solar polycounter lvl 14
Just recently moved over to Max 9 and I'm having trouble turning off the red wireframes around selected faces in the viewport whilst editing UVs. The F4 toggle doesn't seem to remove the selected red wireframe...I'm probably just missing a very obvious button somewhere, can anyone point it out?

Replies

  • Kovac
    Offline / Send Message
    Kovac polycounter lvl 13
    Ah while it might be different in 8 to 9, in UV edit mode you'll see an actual selection in the Parameters section on the right side. Right below Edit and Channel you'll see Display where it shows Show No Seams, Thin Seam, and Thick Seams. It defaults on Thick so that should probably fix your issue.

    Edit: Just remembered I had Max 9 on this box. It's basically the same, though instead of No Seam you just uncheck Show Map Seam. Again, this is right below where the button to edit your UVW window is.
  • solar
    Offline / Send Message
    solar polycounter lvl 14
    I think you've misunderstood me, I'm not refering to UV seams (which appear green) or pelt seams (which appear blue, at least on my setup). I've attached an image which hopefully illustrates the problem a little better.

    redwfuo6.th.gif

    To be clear I'm trying to edit the UVs in the Edit UVWs window whilst looking at the model in the viewport without any wireframes showing at all. Thanks for the reply though.
  • Eric Chadwick
    Odd. Try F2, also might try toggling some of your D3D/OpenGL driver settings.
  • solar
    Offline / Send Message
    solar polycounter lvl 14
    Running in OpenGl seems to fix it, although I'd prefer not too. I've had a look at several people's machines now and it happens on them all. F2 just switches shaded faces on/off.
  • Eric Chadwick
    Bummer. I recently had to turn off "Use Cached D3DXMeshes" to get UVs to show up correctly in the viewport... might be that or another D3D control.
  • Rick Stirling
    Offline / Send Message
    Rick Stirling polycounter lvl 14
    Didn't we discover that it was only on EPoly objects, not Emesh? Or am I dreaming that?
  • Eric Chadwick
    Not sure about that, but I ran into the same thing just now, found that if I turn off the modifier's sub-object mode, it goes away.
  • solar
    Offline / Send Message
    solar polycounter lvl 14
    Yeah, it only happens on Epoly, but surely nobody uses Emesh anymore wink.gif
  • SuperOstrich
    Offline / Send Message
    SuperOstrich keyframe
    Hmmm, I'm not getting this problem, and I only use EPoly. D3D viewport rendering.
  • Eric Chadwick
    If you're not seeing it, that's a good thing, really gets in the way when mapping.

    Make a sphere, convert to Editable Poly, set viewport to Smooth & Highlights, Polygon sub-object, select some faces, turn off Shade Selected Faces (F2). Yuckables.
  • SuperOstrich
    Offline / Send Message
    SuperOstrich keyframe
    Yeah, that's why I'm not seeing it, sorry. I have Shade Selected Faced enabled. If I disable it, I get the same red wireframe. Luckily, you can easily turn it on and off with F2 while working.
  • Eric Chadwick
    I think you're missing the point. F2 merely swaps between making the faces solid red or overlaying a red wireframe. But I want to see the selected faces without any coloring, so I can see if my UVs are seamless with the unselected faces... so then turning off Unwrap's Sub-Object is the trick to turn this stupid wireframe off.
  • SuperOstrich
    Offline / Send Message
    SuperOstrich keyframe
    If you add an Unwrap UVW modifier to an Edit Poly object with no sub-selection, you can press F2 to hide and unhide your red wireframe selection.

    If you select a bunch of faces first and THEN add your Unwrap UVW modifier, pressing F2 does nothing.

    Therefore, I add my Unwrap UVW without a sub-selection every time, and use the Material ID viewer drop down in Edit UVW to view my IDs independently.
  • Eric Chadwick
    Sorry, I think my sphere example didn't help. Try this:

    Make a sphere, convert to Editable Poly but don't activate Sub-Object, set viewport to Smooth & Highlights, UVW Unwrap mod, set Unwrap to Sub-Object Face, select some faces (by ID or marquee), turn off Shade Selected Faces (F2). Do you get the red wireframe?
  • solar
    Offline / Send Message
    solar polycounter lvl 14
    Yeah Eric hit the nail on the head, this only really becomes a pain if you are editing seams or trying to move uvs on the model whilst viewing only the texture - no wires, no shaded faces. F2 will only toggle between shaded faces and the red wireframe.
  • SuperOstrich
    Offline / Send Message
    SuperOstrich keyframe
    Eric, that's so weird. I get the red wireframe if I follow your steps. However if I substitute the sphere with the current model I'm working on, the red wireframe turns off when I hit F2 and there isn't any solid red faces option.
Sign In or Register to comment.