Home Unreal Engine

UE 5.3 low FPS in editor viewport with a 5950X and RTX 3090 (different sample scenes)

interpolator
Offline / Send Message
OccultMonk interpolator

Every example scene I open in the editor seems to be slow. FPS 20-30 and in cinematic mode 10-20 FPS. I have a 16-core 4.3 GHZ CPU and an RTX 3090. I know I can lower the resolution, but even then performance is still not good. Does anyone know what could be the problem?

I am using this free scene: https://williamfaucher.gumroad.com/l/interiorLightingDemoFree

Can someone else test that scene with Cinematic / Epic / High quality? Thanks!

I get this performance:

12 FPS in Cinematic mode
25 FPS in Epic Mode
32 FPS in High mode


Replies

  • Alex_J
    Options
    Online / Send Message
    Alex_J grand marshal polycounter
    looks like enormous cost for lumen in this scene. You can toggle lumen by placing a post process volume in the scene, set the extent to be unbound, and then set the reflection and global illumination to none, rather than lumen.

    I dont have this project, but I am using lumen in my own projects and not seeing cost like that and have similar hardware. If you are going through his tutorial he will likely show you all the things he's enabled.

    just a guess but probably he has cranked up the quality on the ray tracing. You can fiddle with the quality settings of lumen in same place in the post process volume. but its probably most time effective to just continue through the tutorial as he will likely explain everything he has done.

    if that is related to a youtube tutorial you might also search the comments and see if anybody else is reporting similar performance. That would just help to rule out anything particular on your end if it is a common problem.


  • OccultMonk
    Options
    Offline / Send Message
    OccultMonk interpolator
    @Alex_J

    Thanks for the answer. What use is UE5 without GI and Lumen? I mostly want to use it for rendering, not for game development. Also, I believe the creator of the scene has 70FPS with this scene in Cinematic quality with a laptop. So I can't imagine this is normal performance.

    I would really appreciate it if you could test the scene in Cinematic, Epic and High mode. You can download it for free with the link I posted above. I just want to know first if my performance is abnormal vs someone with similar hardware. Then I know something is likely wrong with my setup as the scene will be the same.

    Thanks again!


  • Alex_J
    Options
    Online / Send Message
    Alex_J grand marshal polycounter
    i'll check it out a little later this week if you still need help. It may be quicker to ask the author directly if you can. Also if you have made any changes in the project, it would be worthwhile to grab the original again and test it with no changes. That would indicate whether or not it is due to some change you have made.

    if you have different versions of unreal installed it may also be worth testing one versus another. My hunch is just that there is some quality setting that is cranked up really high. You might ask around tech art related communities as well, they might be able to interpret the profiler details better than i can.

  • OccultMonk
    Options
    Offline / Send Message
    OccultMonk interpolator
    @Alex_J Thanks! I would very much appreciate it if you could test it later. I already tried to contact the author, but no response yet. I don't think I changed anything in the scene by I will redownload anyway. Do you have a 30XX video card? It's not only this scene, I generally seem to have quite a slow performance in Unreal Engine 5.3. I run a 4K screen though, what resolution do you use? 
  • Alex_J
    Options
    Online / Send Message
    Alex_J grand marshal polycounter
    i have two small monitors, like less than 30 inches. the max resolution i use is 1920x1080

    my GPU is an NVIDIA GeForce RTX 3080

    in my main game project i am using lumen but I only have a single light in most levels and I have decreased quality settings with lumen as far as I could as I could not see any difference between that and higher quality settings.

    because the author of that scene you are working with is showcasing lighting specifically and in a small scene, I would guess that he probably has things cranked through the roof. If you are not needing realtime performance but editor slowdown is just annoying to work with, you can temporarily lower the quality settings just for while you are working, then reenable full quality for rendering.


  • pior
    Options
    Offline / Send Message
    pior grand marshal polycounter
    Also, I believe the creator of the scene has 70FPS with this scene in Cinematic quality with a laptop.

    Do you have a link to such footage + the specs of said laptop ? Otherwise any comparaison is quite litterally pointless really.
    Overall UE5 isn't as magical as one may be led to believe. Even the editor alone is slower than UE4.
  • Alex_J
    Options
    Online / Send Message
    Alex_J grand marshal polycounter
    I opened the scene in 5.3.2 and here is my performance:

    It stays pretty consistent like that. I turned the Engine Scalability to cinematic and material quality to epic. In play mode it stays at 60fps.
    I have two monitors on, they both are at 1920x1080 resolution.

    If I turn the screen percentage up that tanks the FPS and gets the fan going. I am not a hardware expert but I assume turning up the screen percentage is comparable to working on a larger monitor.

    If I change the Scalability to High and keep 200% screen percentage I get back to 60fps.


    All of the lumen parameters are maxed out:
    If i revert all those settings to default it doesn't seem to make much difference.

    If I disable lumen that doubles the FPS. However then the lights are completely blown out. I would bet that the author knows more about lighting in unreal than I do, but it does seem strange to me that the lighting in the scene is completely broken if you turn lumen off. I did not think that is how it's meant to work, but perhaps the reasoning is explained in his tutorials. In a game you would need for the player to be able to adjust scalability settings and it has to look correct in each case. Lower scalability settings would likely turn lumen off, so if the lighting is broken in those cases you would have to build a special case to handle it which seems like it shouldn't be the intended workflow to me.
    If there is not a situation where you have to accommodate lower quality settings it wouldn't matter, I suppose, but I just mention this because it seems weird to me.

    In summary it does seem that the editor performance is related to the resolution settings and the size of the screen. I would expect this to be a more likely cause compared to some weird bug.

  • poopipe
    Options
    Online / Send Message
    poopipe grand marshal polycounter
    lumen and nanite resource cost are both resolution dependent so (barring any driver/configuration issues) this is indeed most likely due to resolution. You might get a load of frames back if you switch to immersive mode cos the editor UI eats up a shitload of resources. 
    that said though, lumen does not run very well in editor mode and is absolutely not optimised to do decent frame rates at 4k in editor.

    For reference, my personal game project runs extremely poorly in editor mode (<30fps), approx 40-45fps under play in editor and once built it's in the mid 90s (epic settings  @5120*1440 on a 3080 with lumen and RT shadows)


    I don't believe there's a laptop on the market that comes anywhere close to the capabilities of a desktop 3090 (I have a 3080ti in my work laptop and it's barely comparable to a 3070) so I'm inclined to call bullshit on that 70fps claim unless he's running at 1080p

  • OccultMonk
    Options
    Offline / Send Message
    OccultMonk interpolator
    @Alex_J Thank you for testing and the detailed explanation! It helps a lot. Still 12FPS on 4K for a 3090 is slower even at screen percentage of 200. 

    @poopipe Yes, I read editor performance halved with version 5.3


  • poopipe
    Options
    Online / Send Message
    poopipe grand marshal polycounter
    screen percentage of 200 at 4k means you're rendering at 8k which might be a touch ambitious for realtime work.  

    it's nice to supersample but there are limits :D 
Sign In or Register to comment.