Home Technical Talk

Maya Rigging - Problem with leg and pelvis

DustyShinigami
polycounter lvl 3
Offline / Send Message
Pinned
DustyShinigami polycounter lvl 3

Hi

I did try asking on Maya's Discord channel, but I've had no luck so far, so thought I'd give here a try.

I'm having a bit of an issue with a rigging project that I'm trying to follow as part of a course. This course specifically:

https://www.udemy.com/course/game-character-rigging-for-beginners-in-maya/

Unfortunately, I'm not able to find the guy's contact details anywhere to ask him for help.

In one of his videos, he manages to select the entire left leg armature (thigh), the right leg armature, and then the pelvis, which just consists of a single joint, and then parents it to them with P. When he rotates the hips, everything jiggles and moves like you can see in the first two GIFs...

And then mine...

I'm guessing it's all down to the IK, but I have those set up. I used the Create IK Handle and connected it from the top of the thigh to the ankle, so I'm not sure why it's not working properly. Maybe when the course was done, things have changed slightly in Maya at getting it to work...?

Someone also suggested I may have parented the IK handles to the pelvis, but I've tried doing it again to make sure, but the same thing happens:

So if anyone knows what I'm doing wrong, or could make any suggestions of things to try, I'd be most appreciative. :)

I'm not overly skilled with rigging, though I have done it a bit in Blender and 3ds Max. Though with the latter, it's CAT rigs mainly.

Thanks

Replies

  • DustyShinigami
    Offline / Send Message
    DustyShinigami polycounter lvl 3

    Managed to figure out what the issue was. I'd missed out a crucial step after adding the IK to the leg. I should have gone to the Attribute Editor and under IK Handle Attributes change Stickiness to Sticky. Now it's behaving the same. :)

Sign In or Register to comment.