Home Marmoset

Normals look shiny

node

Hi. For whatever reason, when I import textures over to marmoset, the normals seem to make things look glossy. Is there a way to fix this? Cheers.


Replies

  • EarthQuake

    It's not clear from your image what the problem is. Can you post another image showing what you expect the result to be? If you could highlight the areas that you think are incorrect that may help as well.

    Depending on where you've created the normal map, you may need to enable Flip Y in the material to use the right normal map handedness.

    Generally, the normal map does not control or contribute to the roughness or shininess of the object - that is controlled with the roughness map. So I would make sure that your roughness map has been exported correctly and that your material is configured to read it from the correct channel of your mix map.

  • Ozwaar

    This is how it should look. This is from substance painter

  • Ozwaar

    This the shiny part I'm referring to

  • Ozwaar

    Can anyone help with this? Cheers.

  • Fabi_G
    Offline / Send Message
    Fabi_G interpolator

    Can you confirm that you created an opengl normal map in painter - or if you use a directx normal map, flipped the y channel (as Earthquake wrote)?

    You could upload mesh and normal map, so people can take a look.

  • EarthQuake

    Firstly, the lighting looks quite a bit different in Painter vs Toolbag, it will be difficult to do a direct comparison. I would suggest trying to use the same HDRI panorama for lighting in both applications if you're trying to match the results between the two applications.

    From the latest screenshot, it looks like the normal map is bumpier in Toolbag, I would double-check the exported images and export settings in Painter to make sure there isn't something wrong there, like the bump map strength being set too high.

Sign In or Register to comment.