Home Unreal Engine

Low res shadows with highres Lighting maps

Hey I can not solve the issue of these pixelated shadows.

The Lightingmap res of all meshes is set to 2048, I also tried 4096 rebuilt the lighting but the shadows stay pixelated, no change at all.

Also changing it to 64 has no effect.

I also tired playing with other shadows settings but to no avail.



Replies

  • Fabi_G
    Offline / Send Message
    Fabi_G ngon master

    Hey! If you are talking about the wobbliness, low poly silhouettes can show in the shadows - especially at steep angles.

    And the quality of the lightmap UVs is also important for good results. How does the lightmap UV look? (You could also share the mesh).

    Oh, and obviously the light has to be stationary in order to be baked (to bake static lights, had to change the Global Illumination Method from Lumen to None 🤔)

  • Texmod

    Thanks for the guide but it didnt help in my case.

    This image is taken with 128 sided cylinder as base for the frame, it's a bit less wobbly but still has these sharp spikes everywhere:

    (the cylinder around it has 33.000 tris so that shouldnt be a problem either).

    I attached the FBX I use as well, the mesh is not perfectly alligned anymore because I tried so many iterrations now and didnt care to allign the array modifier till this issue is gone.



    it doesnt seem to be related to my mesh tho, here is with the first person level and you can clearly see the difference between the directional light shadow and the point light shadow whch also has those spikes


  • Fabi_G
    Offline / Send Message
    Fabi_G ngon master

    Heyo! On my side the First Person Example (UE5.0.1) had Virtual Shadow Maps (Beta) enabled as default Shadow Map Method in the Project Settings and "Build Lighting Only" has no effect. To bake light as I used to, I had to switch the Method to Shadow Maps.

    When using Virtual Shadow Maps, this helped me to somewhat improve the shadow border:

    Increasing the light source radius

    default - source radius 0

    source radius of 5

    Using the command r.Shadow.Virtual.ResolutionLodBiasLocal with an value of -1 or -2 gave me smoother shadows borders - found this online, don't know what's behind. Best thoroughly read the docu :)

    source radius = 0 with r.Shadow.Virtual.ResolutionLodBiasLocal -2

    When I switched to shadow maps and baked lights, your the mesh gave me overlapping lightmap UVs errors. This is caused by not everything Unwrapped in UV01 from which lightmap UVs are generated from.

    Here is same situation with baked lighting (after adjusted UV0) with lightmap resolution of 2048


    I would stick with the Virtual Shadow Map Method!

    Added some screenshots.

  • Texmod

    Thanks for the tips, r.Shadow.Virtual.ResolutionLodBiasLocal helped a bit but at a high performance impact for the result so I will stick with increasing source radius even tho I wanted some sharper shadows but rather softer shadows and no spiky spikes :D

Sign In or Register to comment.