Home Technical Talk

[Maya 2022] Maya copy/pastes entire character rig when I try to copy/paste keyframes

polycounter lvl 4
Offline / Send Message
BTDarmstad polycounter lvl 4

Greetings!


I have had this minor issue for as long as I can remember in Maya, where all I want to do is copy and paste animation keyframes, in many cases for animation cycles - and then Maya goes ahead and copies the entire character rig into a new group node.


This has only been an occasional nuisance, until today. Now, Maya won't copy/paste keyframes anymore, only copy/paste everything as described above.


What's going on here?

Replies

  • Alex_J
    Offline / Send Message
    Alex_J godlike master sticky

    Dont select joints. Select keyframes from eitehr the graph editor or the timeline.

  • BTDarmstad
    Offline / Send Message
    BTDarmstad polycounter lvl 4


    I did not select joints in this case, but I did find out what the issue was... Kind of:


    The issue persisted when I tried to do this action on my secondary monitor. When I moved the graph editor to my primary monitor, it copied keyframes without issue. I moved the graph editor to a different monitor a few rounds, and the problem was gone.


    I swear, every week, Maya pulls off another bizarre move like that.

  • Alex_J
    Offline / Send Message
    Alex_J godlike master sticky

    sounds like an issue of which panel has focus.


    Dont have maya open, but if you are adding keyframes, the controls would have to be selected. So if you temporarily had focus in the viewport, or outliner, or somewhere that is not the graph editor or timeline, then when you press copy it would copy what is selected - which would be your controls.

    Thats my guess, but instead of throwing your hands up and blaming the tool, you could test yourself so that you know. It doesnt operate by magic.

  • obrakeo
    Offline / Send Message
    obrakeo polycounter lvl 4

    I think throwing your hands up when Maya get's it's window focus wrong is totally in order. I've come across this as well and it does seem to be an issue of Maya getting focus wrong.. It's been a big issue with node editor vs bifrost graph editor fighting for focus too. It doesn't operate by magic, but it does operate by code that can be buggy and should be fixed, especially something as foundational as copying keyframe animation data.

Sign In or Register to comment.