Home Technical Talk

[Maya] Baking animation clips in Time Editor removes translate values?

polycounter lvl 4
Offline / Send Message
BTDarmstad polycounter lvl 4

Hi!


I'm currently working on my first mocap project, and it's probably not the first time something like this has not been planned properly. Long story short, I did mocap for a character that's way smaller than me, and we didn't do our due diligence with measurements.


So we have a character that has to move further than the mocap data that we have, and I have copied and pasted mocap data to make our character walk further than the mocap does.


Here's the problem: When I bake the animation clips where I nudge the character's root controller along, the root's translate values remain at 0,0,0! I don't like that, I want its real translation values back. I just find it janky and horrible to have a character root jumping around like that. I want to have the root in place, and have the character's CoG do the offset instead. How do I do that? I have Animbot, in which I have tried to copy/paste Xform world space but it doesn't seem like it works (I tried to parent the root to a locator so it would stay in place, but maybe it's the lack of translate values that does it).

I just want my translate/rotate values back.

Sign In or Register to comment.