Home Unity

Update meshes in viewport won't update in camera (game viewport) when hidden or moved why?

decorix
polycounter lvl 9
Offline / Send Message
decorix polycounter lvl 9

Hello all,

I my editor viewport I have refstand but even if I move it away.. its still visible in the game viewport why is this? Like the camera in the game viewport doesn't update. Whats a good way of hidding objects which you don't want to render out in a jpg sequence. I don't want to delete them, but I don't want to render them too. is there a easy trick?




Replies

  • Finnn
    Offline / Send Message
    Finnn polycounter lvl 5

    Via code. You need a reference to the game object (you can use the parent of all the meshes) and use the GameObject.SetActive(bool) function like so:

    RefstandGO.SetActive(false);
    


  • decorix
    Offline / Send Message
    decorix polycounter lvl 9

    Thanks...If I have a camera in my viewport scene and I view it my game view port normally if I move object it should move in the game viewport too. Why doesn't move then? You mean its parent to something else? had working okay other scenes. If I can see the mesh in my game viewport, but it's not in my scene viewport how is that possible? In my Hierarchy some text is highlighted blue what does that mean. Could this perhaps be the problem why this is happening?

  • Finnn
    Offline / Send Message
    Finnn polycounter lvl 5

    That sounds really strange. Some ideas: Check if you are in debug mode. Check if you search for anything in your scene, so everything else not in your result is not visible. Other than that its sounds like a strange issue. Try to restart Unity, maybe reinstall the version you are using. It sounds like an Editor issue, not really like its a problem with your scene.

Sign In or Register to comment.