Home Unity

Render a mesh on Transparant background (png image sequence how?)

decorix
polycounter lvl 9
Offline / Send Message
decorix polycounter lvl 9

Does anyone know why Include Alpha is off? I'm using HDRP and I have changed the color space. I want to render a png sequence with transparent BG. How can I turn it on :-)

Replies

  • Finnn
    Offline / Send Message
    Finnn polycounter lvl 5

    Try to change the diffuse shader (top of the menu) to 'Transparent', this should allow you to import the alpha aswell. If thats not working, you could try to use a black and white mask, basically extract and import the alpha channel manually. Also you said you changed the color space, you might want configure HDRP to output an alpha channel, open your HDRP Asset (menu: Edit > Project Settings > Graphics > Scriptable Render Pipeline Asset)), go to the Rendering section, and set the Color Buffer Format to R16G16B16A16.

  • decorix
    Offline / Send Message
    decorix polycounter lvl 9

    Hi Finnn,

    Thanks for the info again.


    I'm using HDRP and unity latest version 2021.2.11f1


    Is alpha broken? if you wanted to render a sequence


    for rendering out do you do this with time line or Unity recorder?



    > Project Settings > Graphics > Scriptable Render Pipeline Asset)), go to the Rendering section, and set the Color Buffer Format to R16G16B16A16.

    If you have character and just want ot render out png sequence with alpha. Where is it defined? why is it so difficult in Unity?

    -in the camera it self I read that you need to set to black and alpha 0




    can you show me please... ? thanks.

Sign In or Register to comment.