Home Marmoset

Marmoset - Enabling Emissive Glow - Map Worked inside of Substance Painter.

polycounter lvl 3
Offline / Send Message
GarethStandfield polycounter lvl 3
So i have GI on, iv tested the "Bloom" in the main camara and am stumped as to what i need to enable now to make it work? Top image is Marmoset, bottom is Substance. My opacity map also wont work, its either On or off no middle ground, could that be related? 


 

Replies

  • Kanni3d
    Offline / Send Message
    Kanni3d sublime tool
    The "glow" is set to black, try change it to a white/lighter value? 

    Your opacity map likely doesn't work as you intend since it's setting is likely not correct. Translucent will give you the "middle ground" you're looking for. Depends what the opacity map looks like and what its purpose is
  • GarethStandfield
    Offline / Send Message
    GarethStandfield polycounter lvl 3
    Kanni3d said:
    The "glow" is set to black, try change it to a white/lighter value? 

    Your opacity map likely doesn't work as you intend since it's setting is likely not correct. Translucent will give you the "middle ground" you're looking for. Depends what the opacity map looks like and what its purpose is
    Well the map has two different colours on it, red and green, so for marmoset i need to make separate maps for this type of effect?

    Arg the opacity map was from some glasses looks like this.

    But thought maybe both of them might be related to some setting in the camara or the renderer but maybe not the case. 

    This is the map for the glasses, sorry this is so off topic i guess theyre not related, im still struggling to learn about maps and renderers. 

  • Kanni3d
    Offline / Send Message
    Kanni3d sublime tool
    The opacity map drives the color, the "glow" drives the intensity/power of the emissive. If you tint the glow to any color, it'd disrupt what you have in your emissive texture of course. 

    And yeah, so change the shader for opacity to be translucent instead of masked, or cutout (forget which one is on default). Or if you really want, you can forgo the texture, and just have the lens as a separate object/material ID.
  • GarethStandfield
    Offline / Send Message
    GarethStandfield polycounter lvl 3
    Kanni3d said:
    The opacity map drives the color, the "glow" drives the intensity/power of the emissive. If you tint the glow to any color, it'd disrupt what you have in your emissive texture of course. 

    And yeah, so change the shader for opacity to be translucent instead of masked, or cutout (forget which one is on default). Or if you really want, you can forgo the texture, and just have the lens as a separate object/material ID.

    this is what happens when i add a glow colour. :o i will export an opacity map for the glow and see the difference!
  • Kanni3d
    Offline / Send Message
    Kanni3d sublime tool
    Weird, seems like glow is a global setting, thought it'd be only adhere to that emissive mask. Dunno why everything would be a red glow however. It seems set up and working correctly in your original post, but just no glow/bloom.
  • GarethStandfield
    Offline / Send Message
    GarethStandfield polycounter lvl 3
    Kanni3d said:
    Weird, seems like glow is a global setting, thought it'd be only adhere to that emissive mask. Dunno why everything would be a red glow however. It seems set up and working correctly in your original post, but just no glow/bloom.
    Yer its very odd, the map seems to world fludily with no glow but the moment i try use that it just goes crazy over the whole mesh, i thought it might be a bloom/GI problem but nither of them even remotely change the result.  
  • EarthQuake
    The emissive properties in the material editor only control how bright/how much light is emitted from the material. If you have a texture map for emissive, you can ignore the glow color in the emissive section. The glow color will apply a uniform light emission value to the material, which is generally not what you'll need if you have a custom texture map.

    To control how much glow is added to the rendered image, go to the camera settings and adjust the bloom settings. A tip: set the emissive value to a bright HDR value, like 30 (type it in manually), and then set bloom intensity to a very low value to isolate the bloom to the emissive areas 
  • GarethStandfield
    Offline / Send Message
    GarethStandfield polycounter lvl 3
    The emissive properties in the material editor only control how bright/how much light is emitted from the material. If you have a texture map for emissive, you can ignore the glow color in the emissive section. The glow color will apply a uniform light emission value to the material, which is generally not what you'll need if you have a custom texture map.

    To control how much glow is added to the rendered image, go to the camera settings and adjust the bloom settings. A tip: set the emissive value to a bright HDR value, like 30 (type it in manually), and then set bloom intensity to a very low value to isolate the bloom to the emissive areas 
    Thanks i will try checking these settings, the other problem was a tiny little rocket icon i did not know that had to be on for me too see the post rendering effects like Bloom, so experimenting with it while im trying to figure out posing a broken mesh haha
Sign In or Register to comment.