Home Marmoset

Toolbag 4 - Ray Traced Shadow Artefacts

polycounter lvl 11
Offline / Send Message
Ricky polycounter lvl 11
Hi,
I've recently moved up to Toolbag 4 and love the ray tracing capabilities, but keep getting these horrible shadow artefacts only when ray tracing is enabled. It's as if the lighting is looking at a hard-edged version of the model to light rather than taking into account the normals properly with the textures.
With ray tracing:


With raster:


• I've checked the tangent space for the model. it's set to 'Marmoset'. The model was made in Maya, and changing it to that makes no difference. No other option there fixes it. 

• Disabling 'Cast Shadows' on the mesh fixes it, but then means it wont cast shadows on itself. 

• Latest video drivers.

Any help would be much appreciated! 
Thanks,
Ricky

Replies

  • Ricky
    Offline / Send Message
    Ricky polycounter lvl 11
    Found out it only happens when I use HDR images for the skybox instead of jpegs
  • Ricky
    Offline / Send Message
    Ricky polycounter lvl 11

    Bump. I'm also finding this kind of issue with GPU VRay for Maya and in Substance Stager (all different scenes and models). I read somewhere someone say its an issue with GPU renderers, so not sure how to fix this other than changing the lighting setup. If anyone else is experiencing this or similar would be handy to know how others deal with it.

  • EarthQuake

    This is generally expected. What you're seeing here is shadows cast from the low poly geometry. If the low poly geometry had more detail or was more smooth, you would see more smooth, detailed shadows as well. A few things you can try:


    1. Edit the low poly model to have more detail/more closely match the high poly model
    2. Sub-divide the low poly model in Toolbag
    3. Consider adding a displacement map (along with sub-division)
    4. Adjust the Shadow Offset setting in the Render object (Common panel)


Sign In or Register to comment.