Home Unreal Engine

Cascading shadows

Hi all, 

I've been having a weird issue with UE4 shadows losing quality as you get further away from the shadow. 

You can see it here in action, the image on the right is much closer to the face and you can see the cast shadows from the nose, eyebrow. But once the camera gets a bit further away, all that tasty detail disappears. Is there a way to force the shadows to stay at their max resolution? It's a real pain these shadows :/.  

Thanks for reading this, I would love to hear any possible solutions to this problem.




Replies

  • jRocket
    Offline / Send Message
    jRocket polycounter lvl 16
    That is normal. Cascaded shadows work by making more shadow resolution available up close and dropping it further along.
    You can try mitigating the issue somewhat by
    - Increasing overall shadow resolution
    - Changing shadow bias/slope bias in light settings
    - Adjust cascade shadow length/number of cascades/transition power
    - Use contact shadows
Sign In or Register to comment.