Home Adobe Substance

Substance Designer - Precision setting gets ignored after updating to a newest version

godlike master sticky
Offline / Send Message
Obscura godlike master sticky
Hey. I just renewed my license and updated to the latest version of Substance Designer, and I'm noticing some serious precision issues. Some nodes (maybe all, I haven't confirmed yet) straight ignores the bit depth setting, even when I start with a specific precision. I noticed this on warp nodes but theres probably more. I'm just trying to distort some gradient lines with some noise pattern and I'm getting very visible banding. Does anyone else experience this? I don't remember this being an issue in the older version I had before updating, but that was like a year old version. I have a perpetual license and I update it sometimes.The node update seems to be a lot slower than what I'm used to as well. The last one can't be a hardware issue, I'm running a pretty beefy machine.

Replies

  • Obscura
    Offline / Send Message
    Obscura godlike master sticky
    There seems to be some ui bug as well, or maybe it just shows what actually happens. If I set a node to be hdr high precision 32f, it still shows 16f on the node. It doesn't happen on all nodes, but on some of them.
  • Obscura
    Offline / Send Message
    Obscura godlike master sticky
    Look. I'm just trying to warp some damn lines. All nodes the the project is set to 32f:


  • Obscura
    Offline / Send Message
    Obscura godlike master sticky
    In this particular case, using a different node worked though. But the precision settings still gets ignored.
  • Obscura
    Offline / Send Message
    Obscura godlike master sticky
    And what is this?? 

  • gnoop
    Offline / Send Message
    gnoop greentooth
    I am personally so accustomed to all those Designer quirks and puzzles   I stooped pay attention already.    No sbs older than  half a year  works for me.        

    32 bit is not working in half nodes on my side too .  Thus  half of height blending operations is messed  in my old files.  Setting pixel processors inside to 32bit helps sometimes.

    One more quirk:   even if  everything set to work in  floating point math   any material node  still clips  evrything higher than 1     and year ago there was no problem.

    Any 2d transform  makes  slightly blurrier result  than before till you set  it to manual mip level 1

    Severe lack of  anisotropic filtering makes everything blurry at even subtle angle making preview useless . I have to preview in engine  all the time.

    And so on an on.

    Maybe it's why nobody use it except me   ( in  company  I work for)    Too bad there is no alternative  really.


    ps , At least they added dot node inserting  . Not as convenient as in Blender  but still a huge improvement people asked for decade


  • poopipe
    Offline / Send Message
    poopipe polycount lvl 666
    The precision is fixed on some nodes rather than being inherited - why is anyone's guess.

    I generally just build a new version if I need the extra numbers (basically copy it and fix the wrong bits)

    re the viewport filtering artefact - have a look for settings related to SVT
    I've not examined the latest Designer but Painter exhibits similar artefacts and that's had it turned on for a while now
  • Obscura
    Offline / Send Message
    Obscura godlike master sticky
    Hey guys, thanks for the clarification regarding my issues. This is sad because I basically paid for having a much worse version. I don't think designer uses svt, at least I don't find anything related to it on the internet, or inside Designer. Though I found it in the documentation of Painter.
  • haiddasalami
    Offline / Send Message
    haiddasalami polycounter lvl 11
    Tried Designer 2018 as that is what I had and got the same issues


  • Obscura
    Offline / Send Message
    Obscura godlike master sticky
    Now I will try and see if I manually set the precision of those nodes inside them, and resaving, will resolve this issue, but I guess it will. I'll post the results soon.
  • Obscura
    Offline / Send Message
    Obscura godlike master sticky
    Yes, it worked. I went into the perlin noise and linear gradient nodes, changed their precision to be relative to parent, resaved them, and now it works. 

    But this is awful wtf. As far as I see, a whole bunch of nodes has this issue. 

    Thanks for the suggestion though!
  • poopipe
    Offline / Send Message
    poopipe polycount lvl 666
    Yeah, it sucks pretty hard - i can only assume it's done for performance reasons and they're betting that most users won't notice.

    I'd advise making copies into your own library rather than saving over the built in nodes as you'll lose changes with new updates and also occasionally there's a complete replacement of a node alias so menu choices might point at a different file.

    Customising these things is something you get used to - I almost look forward to it.


Sign In or Register to comment.