Home Technical Talk

Minimising Modular character seams

Ottomotto
polycounter lvl 2
Offline / Send Message
Ottomotto polycounter lvl 2
I'm trying to figure out how to minimise the seams on a modular character. As far as I know the seams are caused by the edge vertices having different normal directions. I've had success using average normals under mesh display in Maya, But I cant get this fix to work on export. The normals seem to revert whenever I export the mesh.

Fixed seams:
 
Seams revert to being wrong upon export and reimport. 

Replies

  • sprunghunt
    Offline / Send Message
    sprunghunt greentooth
    You could change the seam to more closely follow the muscles of the neck and exaggerate the muscles there to hide it. 

    In general, for almost every model, it's better to put texture seams along natural borders of the mesh. 

  • gvii
    Offline / Send Message
    gvii polycounter lvl 8
    When you export the mesh, try exporting it using fbx, and when importing, set it to unlock normals BEFORE importing. I've noticed maya wrecks normals unless you unlock them during import.
  • Ottomotto
    Offline / Send Message
    Ottomotto polycounter lvl 2
    gvii That solved it for importing to maya, but not for importing to 3dsmax. Is there any way to get get that to work too?
  • CheeseOnToast
    Offline / Send Message
    CheeseOnToast polycounter lvl 15
    Try this -
    • Unlock Normals on your meshes, to ensure a clean base.
    • Make a copy of your meshes.
    • Combine the separate parts.
    • Merge verts along the seams.
    • Set up the normals as you'd like them on the final mesh, using only Normal > Soften Edge and Normals > Harden Edge
    • Select the combined mesh followed by one part of the final game mesh.
    • Do Mesh > Transfer attributes with the settings below.
    • Repeat for any other body parts.
    • Delete all history.
    • Export FBX with below settings.
    This will definitely survive import into Maya and Max. However, custom normals in Max are very fragile and will be lost easily by adding various modifiers including Edit Poly/Mesh.
  • Ottomotto
    Offline / Send Message
    Ottomotto polycounter lvl 2
    Ok so I've now found out that this is actually an engine issue. I was going insane trying to replicate my lighting to what my client was seeing and trying to get the seams to show up on my end. I never actually had trouble with seams in my test scene in unreal engine, but they did. I assumed it was just more apparent in their lighting setup. 

    I've since found out theyre using UE4 2.25, whereas I was using 2.21. There seems to have been some changes to the fbx importer I'm guessing. 

    2.21: 
    2.25:


    Am I right in assuming this is an import issue? If so can someone point me in the right direction on the import options, I feel like I've tried all of them. 
  • Ottomotto
    Offline / Send Message
    Ottomotto polycounter lvl 2
    And thanks for the pointers CheeseOnToast, I had actually tried that, and like I've said it was fine when I tried it, but apparently it doesnt work in UE4 2.25
  • sprunghunt
    Offline / Send Message
    sprunghunt greentooth
    try Ottomotto said:
    And thanks for the pointers CheeseOnToast, I had actually tried that, and like I've said it was fine when I tried it, but apparently it doesnt work in UE4 2.25
    you could try this:

    1. in the FBX exporter set "smoothing groups" and "binormals and tangents" to ON
    2. in unreal when you import the mesh set the "Normal Import Method" to "import normals and tangents"
    This explicitly imports the normals from your model into Unreal rather than reconstructing them. 
  • Ottomotto
    Offline / Send Message
    Ottomotto polycounter lvl 2
    Thanks sprunghunt. 

    Ive resolved the issue. The vertex normals were wrong and never should have worked in 4.21. Why they did is just going to be a mystery. Updating the project file from 4.21 to 4.25 wouldnt break the model, but reimporting the exact same model would. I tried every combination of the normal import and smoothing group options. I've fixed the vertex normals in 3dsmax with an edit normals modifier. 


Sign In or Register to comment.