Home Technical Talk

Marvelous Designer & Maya Advanced Skeleton issues

Alex_the3DRookie
polycounter lvl 3
Offline / Send Message
Alex_the3DRookie polycounter lvl 3
Hi everyone, 

This is my first post, I was willing to do an introduction but right now I'm in a bit of an emergency for a class project. I'm a student so forgive if I'm asking obvious things. I've done some research but I can't seem to find any solution. Here goes the issue:

I've modeled a character and a friend has done the rigging using the Advanced Skeleton plugin for Maya. (We're using Maya 2020) He's also done the animation. I'm now doing the clothing simulation in Marvelous Designer 9 (5.1.311 version) and we're having serious issues. The character is in a sort of A-Pose (Not really the best pose) but we can't get the rig exported properly to MD. When we export it there's some serious issues in the model itself in MD looks all screwed up not even the joints show up. Exporting just the mesh works but then still no joints in MD (makes sense).
I tried some tests with creating a geometry cache and alembic export of the animation itself, works fine but then we fight another issue:

We are working in metres (in Maya), when importing the mcc cache or alembic, we set it up to metres, then the animation played is at a HUGE scale, like 100x. If I import the fbx mesh in its original pose (no animation), same settings (to metres) then it will read correctly. When I import the animation also if I scrubb around the animation without playing it, it reads correctly the scale when I get it to a certain keyframe. However when I hit play it gets huge again no matter what I do. I've tried cm and....it reads 100x smaller as well as "auto scale". I can't seem to get it to the correct scale, main mesh with no animation works perfect.

I would try simulation to see if it works, but I can't get joints to show up in MD. My friend did one animation per file. The main issue is that since we can't get joints, the morph pose doesn't work with let's say walking animation since it's a walk cycle and the first frame is at a different pose than the original mesh rig pose (which is where I did all the clothing and patterns). (I imported the walking animation, saved the first keyframe as a pose, saved avatar, all the arrangement points & volumes have also been adjusted so we have given up, we don't know what else to do. 

I have a solution in mind but I don't know if it will work: Modify the animation with an offset of 50 frames or so, so that the animation starts in frame 50. from 0-50 start the original pose at frame animating the controllers to 0,0,0 and then get 50 frames from default pose to the first pose of the walk cycle. Generate geometry mcc cache and since the pose will be the default pose, apply the garment and hit the simulation and animation. Save the garment in frame 50 after the simulation to get the garment in the pose I need, save avatar and all that. Then import the original animation and start recording. I don't know if that will work so I'm asking if there would be any issues, since we have 11 animations I wouldn't want to waste that time if there are other workarounds.

By the way just a side note, does anyone know how to export the simulated MD cloth into Unity? We would like to do this after doing the retopo of the cloth but we can't seem to find any info on this, maybe export them individually?

Sorry for the long post but I feel explaining everything to detail would be more helpful.
Thanks in advance!

Replies

  • Yerus
    Offline / Send Message
    Yerus polycounter lvl 4
    Well, I'm not experienced in that, but I'll share what I know:
    - Always work in software native units and never change that (except for stills & co);
    - The solution you presented is the only one I know of, I didn't get what you were doing before.
    - Dealing with simulation is an advanced thing, if you are going to do that you should know all about it.
    - They recommed always to import thing in DAZ scale.
    - To translate do cloth sim into Unity it's better to, first bake the sim into joints, un-sim the cloth and bind it to the joints with skinning.
    Hope this have helped.
  • Alex_the3DRookie
    Offline / Send Message
    Alex_the3DRookie polycounter lvl 3
    Thank you! At the end the issue was solved by exporting the animation to Alembic just the geometry itself. Then I could sim it. I have already simulated everything. I will try what you're saying about baking the sim into joints and skin it. 
    Now I see that I have a bigger problem: Re-topology. I know how it must be done but I don't know if it will work in an animated sim.
    I've seen a ton of videos were they do all the process for static poses but not for an already animated cloth from Marvelous.
    Any idea anyone?
    Thank you for the help!
  • Yerus
Sign In or Register to comment.