Home Quixel Megascans

Answered: Unreal is so slow!

I am using quixel megascans through bridge on my iMac, 4.2 GHz Intel Core i7 with 40 GB RAM, and it takes forever to load things into UE4. Is there some sort of setting I can use to speed things up?


  • Synaesthesia
    Offline / Send Message
    Synaesthesia polycounter
    There's no setting to speed up how Unreal imports assets aside from updating your CPU - this isn't a fault of Bridge, this is simply how Unreal imports assets.
  • Obscura
    Offline / Send Message
    Obscura grand marshal polycounter
    Can't test this with a hdd but in theory, an ssd should do this somewhat faster. I made a quick test with both nvme and sata ssd, and while there was minimal to no difference, it pulled in 4 4k textures in ~3 seconds. That isn't so bad. It would also probably show some difference between these 2 when a lot more stuff is imported at once. I also see that all threads are being utilized during the import so many cores should indeed help. A 16 cores threadripper  was used in this test.

    Edit - I tried out the same test with 74 textures and the import speed was the same with nvme and sata. 1 minute 13 seconds. All 4k. So yeah. Seems like only the cpu matters here.
  • jRocket
    Offline / Send Message
    jRocket polycounter lvl 18
    Probably the texture compression that is taking so long. Turn off texture compression and it will import much faster :) You could also import textures at lower resolutions. You really don't need 8k or even 4k textures.
Sign In or Register to comment.