Enable "Forward Shading" inside "Project Settings" Has Destroyed My Scene forever...









I am so desperate right now.
My 3 months' worth of work just completely gone in a few seconds after I hit "Build" for my level.


So I messed around inside the "render" tab inside "Project settings" in hope of achieving a better-looking result for my scene. I remember enabled "Forward Shading" and after hitting "Build" my whole scene looked completely washed-out and flat (All my materials just don't look right at all, although transparent materials look very good). So I went back into Project Settings to disable "Forward Shading".


Later, no matter how many times I restart and rebuild my level, I just couldn't get back my level to how it looks like before.

I greatly appreciate any bits of help or suggestions.  

Replies

  • Obscura
    Offline / Send Message
    Obscura veteran polycounter
    Forward shading won't look your scene look better. Its an older method that supports less features, and can be cheaper to render. This is why VR projects prefer to use it. Although I still prefer deferred even in vr. The forward shaded transparency CAN be used without enabling full forward shading.In that case, your scene will use hybrid shading.  What really happens when you enable forward shading, and you hit build, is that the objects will use the reflection captures differently. They will not blend because thats not supported in forward. So in theory, this should be fairly easy to fix. I'm guessing your unreal homehow stuck on the built data made while forward was enabled. To fix this, first make sure you saved your level in a separate level file, and you didn't overwrite the default level. I'm mentioning this because in the past it happened that I suggested this fix to someone who overwrote the default level, and the fix basically deleted his level so be careful. So after that, quit the project, go into the folder of it, and delete "saved" and "intermediate". This will delete backups and cache, but leave the actual project files intact. After this is done, open up the project. This time you can expect a longer loading because its a fresh first loading. Make sure you are set to deferred shading, and hit build in your level. If the actual error was unreal somehow being stuck on the forward shading setting, this error should be gone now. If you are still seeing the same results after it was built, it actually wasn't that and the error is coming from somewhere else.
  • Chef_0f_J0EY_SH3rWay
    Obscura said:
    Forward shading won't look your scene look better. Its an older method that supports less features, and can be cheaper to render. This is why VR projects prefer to use it. Although I still prefer deferred even in vr. The forward shaded transparency CAN be used without enabling full forward shading.In that case, your scene will use hybrid shading.  What really happens when you enable forward shading, and you hit build, is that the objects will use the reflection captures differently. They will not blend because thats not supported in forward. So in theory, this should be fairly easy to fix. I'm guessing your unreal homehow stuck on the built data made while forward was enabled. To fix this, first make sure you saved your level in a separate level file, and you didn't overwrite the default level. I'm mentioning this because in the past it happened that I suggested this fix to someone who overwrote the default level, and the fix basically deleted his level so be careful. So after that, quit the project, go into the folder of it, and delete "saved" and "intermediate". This will delete backups and cache, but leave the actual project files intact. After this is done, open up the project. This time you can expect a longer loading because its a fresh first loading. Make sure you are set to deferred shading, and hit build in your level. If the actual error was unreal somehow being stuck on the forward shading setting, this error should be gone now. If you are still seeing the same results after it was built, it actually wasn't that and the error is coming from somewhere else.
    I also notice the way my Reflection Captures behave and tried to tweak them but they didn't fix much.
    It is only after I have deleted those two folders that everything went back to the way they were before. Hat off to you sir for your expertise in the Unreal engine. Top-notch solution!  
  • Obscura
    Offline / Send Message
    Obscura veteran polycounter
    Youre welcome. To get the forward shaded translucency working with deferred, set this to be "surface forward". Screen space reflections checkbox can be enabled to further improve quality.

  • Chef_0f_J0EY_SH3rWay
    Obscura said:
    Youre welcome. To get the forward shaded translucency working with deferred, set this to be "surface forward". Screen space reflections checkbox can be enabled to further improve quality.

    This is great, just a few simple steps but create a huge difference! I have been trying to look for this everywhere, trust me. The reason I went into enabling "Forward Shading" in the Project Settings was because of this and I didn't even know people don't use that method anymore. Again, thank you for speaking your knowledge, you have saved me a lot of time and released the burden that many of us have when trying to navigate this complex software. 
Sign In or Register to comment.