Weird/extreme texture stretching of unwrapped low poly mesh after subdivision - WTF?

Jonathan85
polycounter lvl 5
Offline / Send Message
Jonathan85 polycounter lvl 5
Hello

I have a problem

I have a low poly model that i unwrapped in 3ds max (i didnt pack it correctly yet but that doesnt matter, the island themselves are final). ANd it looks ok, textures are not stretched etc. Everything looks ok to me. But the problem occurs when i try to apply subdivision (turbosmooth) to the mesh, then i get weird texture stretching in some places (the ones around the island in certain places) - check the picture below.
I will need the mesh to subdivide because im planning to put a displacement (modifier) on top. So i need the subdivision, but it looks weird/stretch with it. I know it happens sometimes, but this is an extreme case... How to fix that please, anybody any idead?

Picture link here:

https://i.ibb.co/f8xrctm/Bad-UVs-Texture-Stretch-AFter-Subdivision-How-To-Fix.jpg

Replies

  • rollin
    Offline / Send Message
    rollin polycounter lvl 15
    How does the uvs look of the subdiveded mesh?
    Have you tried to first apply the unwrap modifier?
    Does it work out for you to just tessellate instead of subdividing?
  • Blaizer
    Offline / Send Message
    Blaizer polycounter lvl 14
    Don't worry, that's a problem with the subdivision algorithm in Max they didn't solve in decades.

    If you collapse the turbosmooth modifier, you'll see clearly how your UV has changed on borders/seams. As workaround: It's solved partially subdividing x1 and relaxing again the UV chunks.

    Not all apps have this issue. I work with displacement maps and it's something horrible.

    With low poly subdivision models these issues are very noticeable. Try using mesh smooth modifier instead of turbosmooth, and see if the subdivision algorithm makes the same bad result. Otherwise, just add another UV edit onto a subdivision modifier x1, and relax the polygon chunks.

    BTW, you have a few parts in the UV you can "rectify". UVs will be better and it doesn't take much time, just a click if you have a good add-on or plug-in for UVs.

    hope it helps.
  • Eric Chadwick
    Use OpenSubdiv instead, and adjust the UV settings in it.

    Turbosmooth is ancient tech, there for backwards compatibility only.
  • musashidan
    Offline / Send Message
    musashidan insane polycounter
    As @Eric advised, OpensubD has options to alleviate smooth UVs, but it won't entirely fix it. You can also add in extra support loops to try and 'contain' some of the stretching.
Sign In or Register to comment.