Home Technical Talk

Autodesk Maya 2019 on Red Hat Linux? Anyone?

So I can only get in on the standard Wayland Server through the rescue boot, but I think it is running off of my graphics card and the driver that was installed. I cannot get Autodesk Maya installed. Maybe there is someone at Red Hat who can tell me how to install the latest subscription download that there is. Autodesk does not update their instructions and the download contains a completely different file structure than the example listed on their site for installing using the RPM utility. All I can do is run rmp -ivh on the listed rpm's in the download package. However, all I get afterwards is a maya icon in my software list that does nothing and when taken to its properties it claims that maya_2016.desktop cannot be found and this is for a 2019 install. The actual installation process for the Maya rpm took 2 minutes to install, a little too short I think. Any help I would really appreciate it.


  • TheMuffinMan9

    So I found that the License.env file is supposed to be made in the files that maya created during installation in my root directory. So I followed the directions up to the last part in this link, https://knowledge.autodesk.com/support/maya/learn-explore/caas/CloudHelp/cloudhelp/2019/ENU/Installation-Maya/files/GUID-E7E054E1-0E32-4B3C-88F9-BF820EB45BE5-htm.html?v=2019&st=maya 2019 in linux where it now instructs you to enter your serial number and product number with a certain command. But, I am not sure how to do this. I have a just sign in subscription. I tried replacing the serial numbers with this and I received this response, /usr/autodesk/maya2019/bin/adlmreg -i N “No serial number needed – just sign in” .2 2018.0.0.F “No serial number needed – just sign in” 
    libadlmutil.so: cannot open shared object file: No such file or directory

    I then received this after running the second instructed line. 
    ocalhost ~]# /var/opt/Autodesk/Adlm/Maya2019/MayaConfig.pit 
    /var/opt/Autodesk/Adlm/Maya2019/MayaConfig.pit: line 2: syntax error near unexpected token `)' 
    /var/opt/Autodesk/Adlm/Maya2019/MayaConfig.pit: line 2: `����y�$`X7Q��!���0J�Y����C)�Y�P)�؞�/q� 

    Then here is what happened when I tried running the maya executable as root.


    [[email protected] ~]# maya
    /usr/autodesk/maya2019/bin/maya.bin: error while loading shared libraries: libpcre16.so.0: cannot open shared object file: No such file or directory

    Does anyone have any idea what is going wrong with the installation process or a fix to the matter?

  • Aabel
    Offline / Send Message
    Aabel polycounter lvl 6
    find whatever version of libpcre you have and make a symbolic link to it named libpcre16.so.0

  • TheMuffinMan9
    I found out what it was, something to do with the gnome desktop that comes with red hat system linuxes like CentOS and Red Hat was not working with my motherboard at all. I switched to a KDE Plasma desktop when I installed CentOS and did not install any of the gnome dev tools or anything to do with gnome as instructed by many sites in order to disable nouveau. Now, it works and I can have it for free. Now I just have to hope that Autodesk provides me with a serial number or some way to get in. I would imagine they would put a note that linux version is only for multi license users, but they do not so I think they should. It is only fair, everyone should be allowed to use linux in maya, it is about 200 times more efficient. The install time compared to windows inside linux shows that. Someone who responded on reddit was not so sure that they would, but started this petition inside the autodesk network. Vote here at the link,  https://forums.autodesk.com/t5/maya-ideas/subscription-sign-in-for-linux/idi-p/8929537
  • Aabel
    Offline / Send Message
    Aabel polycounter lvl 6
    @TheMuffinMan9 The problem with the KDE approach is not all applications will support it. For instance Mari. If that isn't going to be a problem for you then no problem! Gnome on the other hand is widely supported. You also do not need Gnome dev tools to disable Nouveau. In the future I would suggest sticking to Fedora, it's a more up to date distro that feeds the development of RHEL/Centos, it's also far easier to find help for.
Sign In or Register to comment.