Issue with reflection of objective on plane in Marmoset Toolbag 3.06

Hello lovely Polycount community! :)

I honestly don't know what to do anymore other than asking here for help. Hopefully someone is able to help me out after trying to explain it as good as possible.

The issue is, the reflection of my can objective looks weird and I don't know how to fix it.

I'm trying to get a nice reflection going but it keeps being weird. I'm rendering already on highest settings possible - as far as I know what I can put on highest of course. I do have Global Illumination enabled + Voxel Resolution on High. I've no idea if there're Reflections Options which I could raise up to increase the outcome.

Following I've a picture to show my issue which is so annoying:



As you can see inside of the white circle, the reflection doesn't look how it should look like...

Hopefully, someone can give me a tip or fix to solve this issue. Please :(

Greetings!

Replies

  • EarthQuake
    This is a technical limitation of the voxel reflection system. The voxel GI / reflections work by creating a simplified copy of the scene to cast rays against. (Turn on Show Voxels to get an idea of what this looks like.) This can result in chunk reflections when you have a mirror-like surface.

    A couple things you can try to improve this:
    1. Set Voxel Resolution to High
    2. Turn off GI, or at least the Specular pass in the GI settings, and only use Local Relections
    3. Try a loss glossy reflective plane and/or adding some normal or gloss/roughness detail to the material to break up the reflections

  • Domii
    This is a technical limitation of the voxel reflection system. The voxel GI / reflections work by creating a simplified copy of the scene to cast rays against. (Turn on Show Voxels to get an idea of what this looks like.) This can result in chunk reflections when you have a mirror-like surface.

    A couple things you can try to improve this:
    1. Set Voxel Resolution to High
    2. Turn off GI, or at least the Specular pass in the GI settings, and only use Local Relections
    3. Try a loss glossy reflective plane and/or adding some normal or gloss/roughness detail to the material to break up the reflections

    Hello EarthQuake!

    Thank you very much for your very fast answer, I greatly appreciate it.

    I was already using Voxel Resolution High which sadly, didn't fix it. However, I've disabled the Specular for now which helped a little bit and made it look more appealing as before. Thank you so much for your help.

    Domii :)
Sign In or Register to comment.