Does Maya 2018 work with GoZ?

polycounter lvl 6
Offline / Send Message
Croftyness polycounter lvl 6
I understand there were some problems with Maya 2017.

Replies

  • kokujinnootaku
    This actually works but you have to do a few things first.  

    1) Instructions:
    Go to path "C:\XXX\Public\Pixologic\GoZApps\Maya"
    Locate GoZBrushToMaya.mel, copy and rename the copy GoZBrushToMaya.mel.bak

    Open GoZBrushToMaya.mel, replace this section:

    // GoZBrushToMaya requires Mental Ray plugin.
    if (`pluginInfo -query -loaded -name "Mayatomr"`==0) 
    {
      loadPlugin "Mayatomr" ;
      //setCurrentRenderer mentalRay;
    }



    To this section:

    // GoZBrushToMaya requires Arnold plugin.
    if (`pluginInfo -query -loaded -name "mtoa"`==0) 
    {
      loadPlugin "mtoa" ;
      //setCurrentRenderer arnold;
    }

    Save the Mel script, happy GoZ-ing!

    2) 
    • First, make sure that Maya is not running before continuing.
    • Click Start > Computer and browse to the Documents folder that contains your Maya configuration files such as: C:\Users\<YourUserName>\Documents. (The exact folder path may vary depending on your Windows version.) Locate any “userSetup.mel” file that you may find in any “scripts” sub-folder. There is a “scripts” sub-folder directly at the root of “[My Documents]\Maya”, but there is also one “scripts” sub-folder for every Maya version. For example, in sub-folders “2009”, “2009-x64”, “2010”, …
    • In each “userSetup.mel” file found, open the file with Notepad.exe and inserts this line at the beginning: eval(“source \“C:/Users/Public/Pixologic/GoZApps/Maya/GoZBrushToMaya.mel\””);
    • If you did not find any “userSetup.mel”, then copy the file “C:\Users\Public\Pixologic\GoZApps\Maya\userSetup.mel” into the “scripts” sub-folder within the “[MyDocuments]\Maya” folder.
    • Now launch Maya. At startup, it will automatically install the new GoZBrush shelf in Maya.
    3) Also, save the GoZtoMaya and GoZfromMaya.mel scripts in the same location as the usersetup.mel you just saved.
    4) Lastly, copy the gozMaya.mll into the C:\Users\<YourUserName>\Documents/maya/2018/plugins file.  

    I tried this with a simple sphere and it worked beautifully both ways.  
  • cromadbomber
    Offline / Send Message
    cromadbomber polycounter lvl 5
    Yes. Just make sure you manually install Mental Ray. 
  • 3draven1
    I'm having trouble with loading gozMaya.mll. Maya 2018 refuses to load the 2017 version.
    Did pixologic put out a 2018 version somewhere?

    I get an error 
    // Error: file: I:/Programy/Autodesk/Maya2018/scripts/others/pluginWin.mel line 290: Cannot find procedure.
     (gozMaya)

    Mental ray installed and loaded, Arnold loaded just in case. Could this be a problem with 2018.1?
  • wirc34
    Offline / Send Message
    wirc34 polycounter lvl 2
    I'm using maya 2018( but should work with other versions if you have this problem)

    The trouble I was having was I could send from maya to Zbrush but not back, it's true having either mental ray installed or switched to arnold in the script helps, for those that have the same issue as I did I just added another existing script on the shelf next to the GoZ one. 

    so just add:  source "C:/Users/Public/Pixologic/GoZApps/Maya/GoZBrushtoMaya.mel"  on the command field and its done.(make sure the script is in the right location)

    NOTE: you have to press the GoZ button in Zbrush first then the one in Maya so it updates the changes made.

    hope this helps some of you!

  • 3draven1
    The problem I have is that maya just won't fire up gozMaya.mll :( Zbrush's goz seems to run maya 2018 but also sends no data back.

    Everything seems to work in 2017 but 2018 just won't recognize the plugin no matter if i browse for it or copy it into the plugin path. Is there a different version of gozMaya.mll that I am missing out on? I only have them up to 2017 in my z-brush folder.
    edit:
    Running the mel script gives me the following

    // Error: line 63: Unable to dynamically load : C:/Users/..../Documents/maya/2018/plug-ins/gozMaya.mll
    .... (errors that cannot find procedure in native windows language)..
    // Error: line 112: Cannot find procedure "gozMaya". // 
    p.s. I'm using mental ray 3.14 for maya 2018

  • Osmar_Artehaga
    kokujinnootaku You forgot something vital to explain.. You gave unfinished information. 
    Step    4) Lastly, copy the gozMaya.mll into the C:\Users\<YourUserName>\Documents/maya/2018/plugins file.  
    Where do we copy the gozMaya.mll from ????????? 
    In C:/Users/Public/Pixologic/GoZApps/Maya/     we have 4 folders. Maya15, Maya16, Maya16.5 and Maya17. I tried them all and they do not work if i try to load them from Maya plug-in Manager. 
    THanks anyways. No one can help
  • 3draven1
    Finally got the damn thing to work. I copied my gozMaya.mll to c:\<programs>/Autodesk/Maya2018/bin/plug-ins and the darn thing loaded.
    plugin information (i in circle in maya plugin manager):
    plug-in version: 2017
    For api version: 20180000
    size: 169 KB (172 KB on hdd)

    Export works both ways...was about to give up :expressionless:
  • 3draven1
    For those people who have problems with zbrush opening a new instance of maya per zbrush->maya GoZ go to zbrush => preferences => init zbrush. Finally everything is working !!!!
  • RawData
    Offline / Send Message
    RawData triangle
    @3draven1 ; can you explain it step by step for everybody? i couldnt manage it to work and confused a bit. Thank you.
  • 3draven1
    RawData said:
    @3draven1 ; can you explain it step by step for everybody? i couldnt manage it to work and confused a bit. Thank you.


    I had problems myself. Could be that the mll file updated during a zb update (got partially through the p3 update)

    The mll only loaded after copying it to my hard drive where maya was installed (not the user => documents!) 

    (below drive is where you installed maya)
    a)  copied gozMaya.mll to my drive:\Autodest/Maya/bin/plug-ins\ folder
    b) copied userSetup.mel to drive:\Autodest/Maya/scripts\ folder (edited the mtoa part like earlier)
    c) copied GoZBrushFromMaya.mel & GozToMaya.mel to C:\Users\<username>\Documents\maya\2018\scripts
    d) copied userSetup.mel to C:\Users\<username>\Documents\maya\2018\scripts (not sure if needed)

    note C:\Users\<user>\Documents\maya\2018\plug-ins is empty on my pc. I copied mine directly to the maya binary folder!

    The plugin info in maya says its the 2017 one with a an api version: 20180000 so could have downloaded with the zb p3 update.

    Connected zb to maya 2018 and also reinitialized z-brush (don't remember if I did force reinstall though)


  • Axi5
    Offline / Send Message
    Axi5 greentooth
    Why does it require mentalray/arnold to transfer models? Seems weird...
  • BIGTIMEMASTER
    Offline / Send Message
    BIGTIMEMASTER interpolator
    Works for me. I set up the pathway from inside Zbrush. Check the documentation for how to do that.


  • RawData
    Offline / Send Message
    RawData triangle
    @BIGTIMEMASTER can you give the link ?
  • BIGTIMEMASTER
    Offline / Send Message
    BIGTIMEMASTER interpolator
    http://docs.pixologic.com/user-guide/zbrush-other-programs/goz/target-applications/


    Disclaimer -- it was a while ago that I did this, so I can't help you further. But my main point was, it does work. I think I had to spend a bit of time troubleshooting as my original path was to Maya 2017, but in the end I remember that I had to delete the old path and update from inside Zbrush. Your solution may be different, but this is well documented so I'm confident you'll figure it out. 

    But honestly, I usually never use GoZ. Reason is I use MayaLT now and haven't bothered setting it up, but also I keep my project folders pretty organized, so export and import is only a matter of a few memorized clicks anyway, and this way I also have my fbx files available for other non-GoZ applications. All in all, I think GoZ is a pretty minor convenience, and maybe only really becomes a game changer for professionals who work really fast and need to worry about shaving off seconds from their workflow. 

    Edit - looks like a made a thread with the same problem a while back. Unfortunately, I didn't write down my final solution. Doh!
  • RawData
    Offline / Send Message
    RawData triangle
    @BIGTIMEMASTER I think you are right , probably Export/import easier than setting up goz
  • 3draven1
  • Pabs
    Offline / Send Message
    Pabs polycounter lvl 6
    keeps opening up a new instance of maya. what do?



    EDIT: solution found
    https://miloblogger.blogspot.com/2010/09/some-gozbrush-issues-solution-in.html

    Open Maya, now you can see the GoZBrush shelf in your Maya shelf.

    Open Shelf Editor, select GoZBrush then change to Edit Commands tab. Just add one more line below the first line*2:
    source "C:/Users/Public/Pixologic/GoZApps/Maya/GoZScript.mel" ;
    (This is solved GoZ launching multiple instances of maya issue and Maya→ZBrush does not success issue.)

    *2:Remenber add ";" in the end of each command line :
    source "C:/Users/Public/Pixologic/GoZApps/Maya/GoZBrushFromMaya.mel" ;
    source "C:/Users/Public/Pixologic/GoZApps/Maya/GoZScript.mel" ;
Sign In or Register to comment.