Solved: Custom Materials come out looking White

Offline / Send Message
Pinned
So I'm trying to create a simple Custom Material.

I select the 'Import a Custom Material' option in dDo and add my Albedo, Spec, Normal and AO. It looks fine in the Preview Mesh, just how I'd like it so I select 'Create Material' and apply it to my custom mesh and its all white!

It's loaded my Normal Map and my AO fine I can see that. I though it might be because of my Spec Map being to intense or something so just for good measure I created another Custom Material with JUST the Albedo and it's still white. WTF? And it's just my Custom Materials, if select my Maps in the Base creator (Normal, AO, Prebaked Albedo and Spec) the model looks fine. But I'd like to add Materials Quixel Suite doesn't have so I may use them in the future if I need to.

I am relatively new to Quixel Suite 2.0. I'm sure theres a some super simple solution to it but I'd appriacte some help.

Replies

  • Synaesthesia
    Offline / Send Message
    Synaesthesia interpolator
    Hey Griffo!

    Currently, you need a specular map for the albedo to properly display. It should function with no problem regardless of whether it has a specular map hooked up, but it'll be a white ball for the time being. A workaround would be to use a flat black texture as your input for the simple albedo if you'd like to see the texture on the shaderball. :smile: 

    However, the rest of your issue seems like less of a shaderball problem and more of a general bug. Before I pass it on, could I take a look at your input maps? I'd like to try them out and see!
  • Griffo
    Hey there,

    Thanks for getting back so quickly, I didn't expect one so fast.

    Yes of course you can see my input maps. I've also gone ahead and left the original maps I created in Photoshop, the Maps created from Quixel from the Project, and the Project itself. It's a file too large to attach so I've left a link to the folder with the content to Dropbox, I hope this is okay.

    It maybe worth mentioning; I also encounter the same issue when attemping to create another Custom Material (a Soil texture), however when I made one prior to this (a flower petal texture) it seemed fine. I had Colour, my Normals were showing, everything was good. It was only when I tried to make one after I started running into the issue. 

    I haven't messed with any of the settings to my knowledge that might have triggered the problem. But please by all means go ahead and look for yourself, I hope you can help :)

    Many Thanks

    https://www.dropbox.com/s/8zk2kgsrmuu6gc7/Flower%20Pot%20Project.zip?dl=0
  • Synaesthesia
    Offline / Send Message
    Synaesthesia interpolator
    The forum ate my last post, so I'll re-post:

    I loaded your project and created a custom material from the flower pot maps you gave me. What I believe is happening is that you haven't set the color value inside of DDO. The color on the albedo input will be turned grayscale as a Photoshop pattern for DDO to work with, so you'll need to manually change the color of the material in your albedo channel. It's the box next to the DynaMask preview in the main DDO window. :smile: 

    Let me know if that helps!
  • Griffo
    YES! That did it, thank you! I knew it would be something simple like that.

    But I'm a little confused. If I've already declared the colour of the texture in my Albedo, (in this case a dull orange) why do I have to apply it again manually when the colour has already been assigned to the material? 

    Thanks for you help I very much appreciate it :)
  • Synaesthesia
    Offline / Send Message
    Synaesthesia interpolator
    Custom materials lose their color information once loaded into the Suite as a Photoshop pattern. They turn grayscale so you can edit the color values to anything. :smile:
  • Griffo
    Ahhh I see how that can be useful now that you mention it.

    Thank you very much for helping me with my problem, I really appreciate it.

    Many thanks 
  • Synaesthesia
    Offline / Send Message
    Synaesthesia interpolator
    You're quite welcome, that's what I'm here for! :smiley: 
Sign In or Register to comment.