Cat rig problem - foot platforms

polycounter lvl 5
Offline / Send Message
LeeMeredith polycounter lvl 5
Hello, we were given a cat rig to animate a jumping/wall/pole swinging scene and I went away and animated my block in but over the course of several full body rotations and turns, the foot platforms have moved away from the foot and now cause the feet to pivot in a strange way, does anyone have any ideas how to fix it? 




I've tried saving a full body pose on a previous key and loading it on the broken ones but it doesn't fix it, I also tried resetting rotations but it was still in the wrong position, oh and I tried moving IK to palm or whatever the dialogue option is.

Thanks for any help.

Replies

  • Chaucer
    Offline / Send Message
    Chaucer polycounter lvl 8
    There is probably something in the underlying rig that got shifted somehow (Like a group node or something). Sometimes that's just a bug with the rigging that needs to be cleaned up, or that the animator accidentally selected a parent object and moved it when those things should be locked.

    So try pressing "up" on the keyboard with the controller selected and see if there's any parents that should be zero'ed out that you may have accidentally moved.

    If doing that doesn't provide a solution, this is one of those instances where a solution would probably be very specific to your rig or scene. 
    Can you post your animation sequence or is the rig available online somewhere that I look under its hood. That way I can try to help provide you a specific solution if needed. 
  • LeeMeredith
    Offline / Send Message
    LeeMeredith polycounter lvl 5
    Hey Chaucher, I think this is basically just a normal cat rig with the limbs positioned differently, I tried pressing up but it just zoomed in, I should clarify that this is in 3ds Max, I tried zeroing out the foot platform and the actual foot but it just breaks it even more, I also tried switching to auto tangents but didn't fix it. If you don't mind taking a look I have two saves files available via dropbox, they are 3ds max 2013 and 2016.  The problem happens to the yellow foot at frame 55 and from then onwards and the other foot starts to break sometime after that. 

    https://www.dropbox.com/s/1hxf1qp0kr0u7gu/LeeM_FootPlatforms2013.max?dl=0

    https://www.dropbox.com/s/0tnmawxjvndexnu/LeeM_FootPlatforms2015.max?dl=0

    Really appreciate the help.
  • Chaucer
    Offline / Send Message
    Chaucer polycounter lvl 8
    Ah my apologies. I don't know 3ds max to help you specifically. But the concept of what I was saying should still carry over. 

    IMO It has nothing to do with tangents or the controller itself. There should be a way to check the hierarchies in max. (scene manager?) So just take a look at what the parent of the controller is and see if things got shifted. 

    Since you posted the files, someone with Max knowledge may help guide you through that, if you aren't familiar with "looking under the hood."

    Sorry I can't be of any help.
  • Hito
    Offline / Send Message
    Hito interpolator
    You have translation keys set on the Foot bone, and it's treated as an Offset from the platform by CAT. if you delete the translate key, the foot will match the platform again @ 55 and after. Probably good to go through the bones periodically and clear out stray key frames until polish time
  • LeeMeredith
    Offline / Send Message
    LeeMeredith polycounter lvl 5
    @Chaucer thanks for trying, I appreciate it.

    @Hito you're a hero, that worked perfectly, I don't even remember adding movement to the feet, thanks a lot!
Sign In or Register to comment.