Home Chivalry: Medieval Warfare

modo to UDK vertex normals

Offline / Send Message
Bek greentooth
I'm following this tutorial by Torn Banner for adding custom weapons. I'm using modo 701sp4 and the FBX 2013 exporter with the following options enabled:

Save Mesh Geometry
Save Mesh Smoothness

I can see in toolbag 2 for instance that the smoothing has been exported correctly (Although re-importing into modo yeilds weird results but that's another issue). When I import into the chivalry editor I get:


And none of the mesh smoothing imports. Any ideas? I also tried FBX 2010 and playing with the 2013 options to no avail.


  • Ramseus
    Offline / Send Message
    Ramseus polycounter lvl 10
    With 701 I only use FBX 2010, with 2013 I don't know if it's modo or unreal but one of them doesn't agree with the FBXs and getting smoothing seems to be impossible. I forget what export settings I had in 701 and I can't look at right now but 2010 works fine. If you're not getting the warning with 2010's but still not getting smoothing, make sure 'preserve smoothing groups' is checked for skeletal meshes and 'explicit normals' is unchecked for static meshes.
  • Bek
    Offline / Send Message
    Bek greentooth

    I ended up just using the split function on my UV seams (which were hard edges) and that let me get the correct shading for the skeletal mesh. My understanding is that does pretty much the same thing.

    I also had a bug with the exported 2013 FBX was larger (in scale) than it should have been, but I'll try 2010 and report back.

    edit: I was mistaken, what was actually happening was importing the source FBX from torn banner into modo was incorrect in scale if Use FBX 2013 Loader was checked in FBX preferences.

    Also 2010 from modo exports oddly large files (1mb instead of 200kb), did you guys at torn banner use the FBX converter to reduce the file size? I'll play around with that later. Or maybe I'll just use 2013 and split edges.
Sign In or Register to comment.