Gradiant Mapping Problems

polycounter lvl 8
Offline / Send Message
AlanSMitchell polycounter lvl 8
Pretty straight forward I saw this Link and it inspired me to work out a way to utilize gradiant maps as well. Unfortunately it's not as easy as I would have thought to make/work. I'm not sure what exactly I'm doing wrong because I followed Andrew Maximov's example file that he gave out on the link above. I also just copied and paisted the material nodes from the working file to my package.
I tried simplifying the problem in a test material.
material expression
MaterialExpression.jpg
material function
MaterialFunction.jpg
material hightmap! just so you can see there is something in the alfa.
MaterialExpressionHightWorking.jpg

Any help is much appreciated!
Thanks in advance

Replies

  • Ace-Angel
    Offline / Send Message
    Ace-Angel polycounter lvl 6
    Don't use the Functions with Alpha, they don't mask correctly, unless you use a Mask Component Node, but then things can get complicated with you having to define if it's V4/V1, etc.
  • |*BILLY$CLINT*|
    Anyone have a link to the package. The download link that he provide is broken...N/M I got it working.
  • AlanSMitchell
    Offline / Send Message
    AlanSMitchell polycounter lvl 8
    Anyone have a link to the package. The download link that he provide is broken...N/M I got it working.
    try going to the youtube video.
    "free giveaway"
    also on the website ditching the diffuse there is a image near the bottom that says "download"

    Hopefully one of those works ^^
  • AlanSMitchell
    Offline / Send Message
    AlanSMitchell polycounter lvl 8
    Ace-Angel wrote: »
    Don't use the Functions with Alpha, they don't mask correctly, unless you use a Mask Component Node, but then things can get complicated with you having to define if it's V4/V1, etc.

    Thanks I will have to try that.
  • sprunghunt
    Offline / Send Message
    sprunghunt polycounter lvl 12
    I haven't downloaded the file and looked at the code but I'd suggest that you try doing the same functions as separate nodes rather than by using a custom node.
  • AlanSMitchell
    Offline / Send Message
    AlanSMitchell polycounter lvl 8
    @ sprunghunt: I'll see what I can't coe up with. I would just like it to work. lol
    http://technical-eden.blogspot.com/2012/01/gradient-mapping-awesome-way-to-get.html
    but I'm not sure how I could create the same thing without a custom node. :/
    I know there is a million ways do do anything in UDK so I will have to try it out I guess.
    I'm going to try another test in a new package and see if I can't anything working. I have never heard of a pakage just breaking unless it's ambiguous package name. but it doesn't hurt and redoing everything and all the steps I might just fix it.
  • Ace-Angel
    Offline / Send Message
    Ace-Angel polycounter lvl 6
    I'm not too sure either how you would do it via Nodes in UDK Procedurally, the quickest solution I would imagine is you keep on Power-ing the Term from each color by the power of 2, and Lerping one into another, till you connect to the Weight Map.

    But I have used this method for the Traditional Gradient mapping (with a Lambert term), so I could be totally wrong for the this method.
  • AlanSMitchell
    Offline / Send Message
    AlanSMitchell polycounter lvl 8
    Ok it looks like UDK hates my old package I'm doing everything right but maybe there is a shader problem in some old code. I'm not quite sure exactly
    workingtestpackage.jpg
    (ignore the hidious colors) lol
    I tried moving the working material into my package and it's just broken.
    I wasn't a fan of what I named my old package anyways on top of that I could only get the red channel in my vertex blending to work maybe it will work now with this new package too. ^^;;
  • d1ver
    Offline / Send Message
    d1ver polycounter lvl 9
    Hey Alan, in my experience unless you use ComponentMask node with material functions it will always use the red channel of your map messing things up. It also shows no error so I was literally banging my head against the table trying to figure out whats wrong. Bugs be damned:)
    In my mats it works like this:

    Function_Mask.jpg

    also you might wanna check the alpha values of your color nodes - they should be in consecutively increasing order.

    please give it a try and tell us how it went. sorry it took me a while to get back to you on youtube.

    cheers;)

    EDIT: oh hey, I'm glad it works for you:) I'll just leave it here anyway.
  • AlanSMitchell
    Offline / Send Message
    AlanSMitchell polycounter lvl 8
    mythoughtsexactly.jpg
    So sad all the time. lol
    oh yeah I tried making a gradient map for the vertex blending. I am getting all sorts of errors I will prolly make a new thread and post new problems up there. It looks like you worked around some huge technical issues to get the vertex blending to work right. I just assume it will work right; I put a gradient map material function on the diffuse texture, copied the same gradient map for the snow diffuse texture, and ice diffuse texture = material turned white, I started deleting everything and it couldn't handle 1 gradient map material function. Again this is my first time dealing with material functions so it's kinda hard to figure out the things I need and the things I don't because it should be repurposed for what I'm doing. from what it looks like you shouldn't copy paist the same meterial function in the same material. I assume because you made a new graidient mapping function for the spec. Honestly I thought I was really good at the material editor but I'm looking like a noob right now. ^^
    I will prolly post a new thread + new problems sometime tomorrow I'm tired.
Sign In or Register to comment.