Home Technical Talk

Importing UV's into sculpted mesh in ZBrush

Hey there all,

I'm wondering if it's possible to import UV's to a mesh that's already got several levels of sculpted detail in ZBrush?

For example, if I brought in a base mesh that doesn't have UV's, or if I've sculpted something out so much that the original base UV's are inadequate (resulting in stretching if I was to polypaint etc)... can I then export out the lowest SubD level, give it UV's and then import the UV's and have them apply to all SubD's.

I've seen a few instructions suggesting it can be done, but they're a little vague. It looks like the way to do it is to export lowest SubD, UV it, then import the UV'd mesh.

What I'm not sure of though is how to reimport it as a subdivision level and retain my higher levels with the new UV's (if it is possible).

Thanks

Replies

  • Tom Ellis
    Ah figured it out;

    Export lowest SubD level from ZBrush

    Unwrap in software of choice and save

    Back in ZBrush at lowest SubD of mesh (that was exported) click 'Morph Target > Store'

    Import new UV'd mesh while at lowest SubD level

    Click 'Morph Target > Switch'


    There may be an easier way but this worked for me!
  • CheeseOnToast
    Offline / Send Message
    CheeseOnToast polycounter lvl 15
    I'm recently finding that this isn't working for me any more. If I import the new UV'ed mesh as a level 0 subdivision, it's UVs are lost into the ether. If I bring the model in as a standalone, it's UVs are intact. Got around it by using copy/paste from the new UV master plugin, in case anyone else is having the same trouble.
  • Tom Ellis
    It's funny you should say that because I'm sure I've tried it before and had the same problem.

    I'm not sure if it makes a difference but when I saved the UVd OBJ, I just saved over the original rather than saving it as a different file. In sure that doesn't make a difference though thinking about it because that all happens outside of ZBrush.

    Another thing I did was switch to another tool and import the UVd mesh then switch back and import again.

    Again though, i doubt that would make a difference.

    It's working though so let's hope it continues to!

    Thanks for the UV Master tip too, I haven't tried that yet but it's something I've been meaning to check out.
  • chrisradsby
    Offline / Send Message
    chrisradsby polycounter lvl 10
    Well I've always done it like this

    Export lowest subdivision from Zbrush
    Unwrap the .obj file
    Import the .obj file in Zbrush using the import button and having the right subtool selected.

    Then it works, no need to use morph target.

    I've used this since Zbrush 3.1, why wouldn't it work on later versions?
  • James Edwards
    I'm recently finding that this isn't working for me any more. If I import the new UV'ed mesh as a level 0 subdivision, it's UVs are lost into the ether. If I bring the model in as a standalone, it's UVs are intact. Got around it by using copy/paste from the new UV master plugin, in case anyone else is having the same trouble.

    Nice find!

    GoZ has worked pretty well for this too so far. Send subtools to modo using GoZ, uv them and then send them back thru GoZ again. Also worked great for a couple of quick mesh tweaks, like creating internal mouth geometry from a previously closed head mesh.
  • CheeseOnToast
    Offline / Send Message
    CheeseOnToast polycounter lvl 15
    Well I've always done it like this

    Export lowest subdivision from Zbrush
    Unwrap the .obj file
    Import the .obj file in Zbrush using the import button and having the right subtool selected.

    Then it works, no need to use morph target.

    I've used this since Zbrush 3.1, why wouldn't it work on later versions?

    Good question. I messed around for ages, making sure my OBJ had UVs, testing it in other software etc. etc. I think it might be an occasional, inconsistent bug introduced in version 3.5r3.
  • thomasp
    Offline / Send Message
    thomasp ngon master
    it might be dependant on which 3d app you use in tandem with zbrush and/or what your export/import settings are. i know i had this working one or two years ago with Z3.1 and max but i can't get it to re-import correctly these days with the same software versions on a different setup.

    will try the morph target route. :)
  • Tom Ellis
    Ah yeah ChrisRadsby, just tried without the morph target and it does work just fine.

    Last time I tried it and had problems, I'd exported from Max, but this time the OBJ came from UVLayout and worked perfect. I think it may well be down to export settings.

    I just use the default UVLayout export (not sure if you can even change the settings) so it could be that certain settings when exporting from a 3D package cause a problem somewhere along the line.
  • hosch
    I am using the method listed above and the UVs are being imported properly (as tested in UVMaster in flattened mode), but are not being displayed properly in unflattened mode in our out of UVMaster.

    The faces in unflattened mode seem to be positioned properly, but look to be rotated 25% clockwise.

    Images and more detailed description are listed here:
    http://www.zbrushcentral.com/showthread.php?t=86271
  • chrisradsby
    Offline / Send Message
    chrisradsby polycounter lvl 10
    Ah yeah ChrisRadsby, just tried without the morph target and it does work just fine.

    Last time I tried it and had problems, I'd exported from Max, but this time the OBJ came from UVLayout and worked perfect. I think it may well be down to export settings.

    Great that you got it figured out then man :) I've always done it like that, never had any problems as long as the topology/polycount didn't change.
  • hosch
    I am getting reordered point errors upon reimport - think that is the problem, but not sure how it is occurring.


    It must be because it is even doing the same thing when I use AUV or GUV UVs.
  • sebas
    Offline / Send Message
    sebas polycounter lvl 13
    @ hosch: Have you tried Tool/Texture/CicleUV several times until you get it 'ordered'?
  • hosch
    Sebas - YOU FREAKING ROCK - I spent almost 5 hours troubleshooting this and you came in and saved the day, heh - now to get back on track for my deadline this evening! Thanks much!
  • hosch
    JUST FYI - the tool is actually at Tool > UV Map > Cycle UV, but I knew what you meant as soon as I read your post.
Sign In or Register to comment.