Home Low Poly Challenge

LPC STYLE GUIDE

polycounter lvl 14
Offline / Send Message
hawken polycounter lvl 14
Turning off antialiasing & filtering.

spacey_tf2splash.jpg
("meet the team" by Spacy http://www.tomtallian.com)

Above is, perfection.

But you may be asking, "how do I make my software do that!?"

Here is a list of methods to get your low poly renders looking perfect.

Cinema 4d:
gray background: Either grab the viewport, or make a background object and texture it gray.
no antialiasing: Either grab the viewport or turn off in render settings.
no texture filtering: Check sampling to "none" in the texture you're applying.

3ds max:
gray background: Either grab the viewport, or open Rendering & Environment and set the background color.
no antialiasing: Either grab the viewport or un-check the "Antialiasing" checkbox in Renderer tab of the Render settings.
no texture filtering: For viewport, go to Customize & Preferences & Viewports tab & Configure Driver and set Texel and Mipmap Lookup to "Nearest" and "None". For rendering, un-check "Filter Maps" in the Renderer tab.

maya:
gray background: Grab viewport, or select current camera & Attribute Editor & CameraShape & Environment & Background Color
no antialiasing: Grab current viewport, or use Window & Rendering Editor & Render Settings & Maya software & Anti-aliasing Quality & Low quality
no texture filtering: For viewport, choose Shading & Hardware Texturing & Texture Filter & Unfiltered

blender:
gray background: Shading (F5) & World Buttons & World
no antialiasing: Scene (F10) & Render Buttons & Render & turn off 'OSA'.
no texture filtering: Shading (F5) & Texture Buttons & Map Image & turn off 'Interpol'.

modo:
gray background: for viewport grabs: system>preferences>display>colors>background>change background color. For render: shader tree>environment>environment material>environment type>constant>change zenith color
no antialiasing: Must change per image map. Works with renders and viewport grabs: shader tree>image map>texture layer>uncheck antialiasing.
no texture filtering: Must change per image map. shader tree>image map>texture layer>texture filtering>nearest

XSI:
gray background: Viewport Grab, or Render & Options & Render Engine, Open GL, Background Color, 0.5 all RGB values
no antialiasing: Viewport grab, or Render & Options & Aliasing & Max Level 0
no texture filtering: Select textured object, Get & Texture & Image & from Material:Image property window select Edit (Image) & Texturing tab, select 'Uninterpolated pixel' under OpenGL Texture Settings for both far and near filters...or Press 8, open object material property, click Color connector, follow previous steps starting at Material:Image property window.

silo:
gray background:
no antialiasing:
no texture filtering:

Replies

  • Indecom
    Offline / Send Message
    Indecom polycounter lvl 11
    <font color="green">gray background:</font> In world Settings, set each color bar to half
    <font color="green">no antialiasing:</font> Uncheck OSA in render settings
    <font color="green">no texture filtering:</font> Uncheck OSA in render settings


    <font color="red">software?</font>
  • MoP
    Offline / Send Message
    MoP polycounter lvl 14
    Added the 3DS Max info.
  • Zwebbie
    For Blender:

    Gray background: Shading (F5) -> World Buttons -> World
    No anti-aliasing: Scene (F10) -> Render Buttons -> Render -> turn off 'OSA'.
    No texture filtering: Shading (F5) -> Texture Buttons -> Map Image -> turn off 'Interpol'. No idea if it's possible in viewport.
  • sama.van
    Offline / Send Message
    sama.van polycounter lvl 9
    For Maya :

    Gray background: Render : Select your current camera -> Attribut Editor -> CameraShape -> Environnement -> Background Color (and pick color)

    No anti-aliasing: Render : Hotbox -> Window -> rendering Editor -> Render Settings -> Maya software ->Anti-aliasing Quality -> Low quality

    No texture filtering: Viewport : Hotbox -> Shading -> Hardware Texturing -> Texture Filter -> Unflitered
  • Indecom
    Offline / Send Message
    Indecom polycounter lvl 11
    Sorry, i wrote blender in there and must have accidentally deleted it when i edited the post.
  • ElysiumGX
    Offline / Send Message
    ElysiumGX polycounter lvl 15
    For XSI (softimage is the company, not the software):

    gray background: Viewport Grab, or Render -> Options -> Render Engine, Open GL, Background Color, 0.5 all RGB values

    no antialiasing: Viewport grab, or Render -> Options -> Aliasing -> Max Level 0

    no texture filtering: Select textured object, Get -> Texture -> Image -> from Material:Image property window select Edit (Image) -> Texturing tab, select 'Uninterpolated pixel' under OpenGL Texture Settings for both far and near filters...or Press 8, open object material property, click Color connector, follow previous steps starting at Material:Image property window.

    For a large non-printscreen viewport grab: Click on viewport camera icon, Start Capture. Change format, Image Size, set Sequence for 1 Frame. Uncheck Flipbook, and Anti-Aliasing.

    (may vary depending on version and layout (mod tool))
  • Viniterra
    Don't believe I've found how to disable texture interpolation in Blender, i was under my noise all the time!
  • Slingshot
    Offline / Send Message
    Slingshot polycounter lvl 13
    Thanks Hawken!
    I am re-learning 3Ds max for my DOW3 project and forgot all about the antialiasing & filtering part.

    DOWIII Entry
  • seven
    Offline / Send Message
    seven polycounter lvl 9
    Modo:

    gray background:
    1. for viewport grabs: system>preferences>display>colors>background>change background color
    2. for render: shader tree>environment>environment material>environment type>constant>change zenith color

    no antialiasing:
    Must change per image map. Works with renders and viewport grabs: shader tree>image map>texture layer>uncheck antialiasing
    for renders only:
    shader tree>render>settings>antialiasing>1 sample/pixel
    shader tree>render>settings>antialiasing filter>box


    no texture filtering:
    for renders and viewport grabs. Works with renders and viewport grabs:
    Must change per image map. shader tree>image map>texture layer>texture filtering>nearest
  • D4V1DC
    Offline / Send Message
    D4V1DC polycounter lvl 13
    What's up with the coding on these forums? the first post is ruined :( I like the format seven is using.
  • hawken
    Offline / Send Message
    hawken polycounter lvl 14
    updated! now all we need is some silo info
  • Vrav
    Offline / Send Message
    Vrav polycounter lvl 10
    Silo:

    gray background:
    editors/options > display settings > uncheck draw viewport gradient
    editors/options > color settings > viewport background

    no antialiasing:
    if you've AA in Silo, force disable it via your videocard control panel; many users have already disabled it due to a selection bug that occurs with AA enabled.

    no texture filtering:
    not sure if this is possible, have tried so many combinations in the nvidia control panel as it is; if anyone can figure out a way, that would be awesome. but silo still can't render alpha in textures, so it might be a lost cause - an alternative application for presentation is desirable.
  • BradMyers82
    Offline / Send Message
    BradMyers82 greentooth
    Setting up Materials for Low Poly Presentation // 3ds Max:

    I have seen people make the mistake of not showing their characters or objects with 100% illumination.

    Or in other words, they are allowing the software to shade the polygons which makes everything look like garbage. It probably seems like common sense to a lot of the veterans around here, but I'm sure it's new to the people just getting started.


    In 3ds Max: The simplest solution is to "right-click" next to the viewport title (usually next to "[Perspective]" In the top left part of the screen and you are clicking on "[Smooth + Highlights]")
    Instead of "[Smooth + Highlights]" Choose: "[Flat]" like shown in the image below (see red circle).


    Of course, don't forget to go to "Customize>Preferences...>Viewports (tab)>Configure Driver (button)>and choose "Nearest" at the bottom under "Texel Lookup"
    Which as explained above turns off texture filtering.


    Lastly make sure that your viewport supports the texture size you are using.

    Easiest way to do this... Go to: "Views>Show Material In Viewport As>Hardware Display With Maps"

    Again, this will ensure that you textures are not compressed in the viewport, and you are seeing them at full resolution.


    Hope this helps!


    ExampleOfLowPolyPresentation.jpg
  • Delzhand
    Offline / Send Message
    Delzhand polycounter lvl 7
    In Blender 2.59 (probably as far back as 2.5 and still the same in 2.6 I believe), you can turn off texture interpolation in the viewport in the User Preference pane - under System uncheck the box for Mipmaps. I struggled to find this for a long time, and most of the google search results were for renders only.
Sign In or Register to comment.