How to align HP to LP for baking in Substance painter

triangle
Offline / Send Message
M u r t t i triangle
Hello,

What would be the best (easiest) way to align high poly and low poly meshes for baking in substance painter? My workflow so far goes like this:

1. Create base low poly model in 3ds max
2. Import LP mesh to Zbrush. Dynamesh -> Sculpt details -> Decimate -> Export (fbx) to 3ds max.
3. Import HP export to same scene with LP in Max and align objects and also scale HP to match LP. 
4. Necessary modifications to LP to match HP mesh and after that unwrap LP.
5. After unwrapping export LP to Zbrush, align LP and HP meshes and then export HP mesh for baking.
6. Open LP in Substance and bake HP details on it.

Questions:
-I cannot align final meshes in Max cause it crashes because of too many polygons (due HP model in scene). Is there an easier way to align these meshes somehow?

- point 3: Is there a way to match the scale and position for HP sculpting model in Zbrush to match imported LP model so I wouldn't need to rescale and reposition meshes again in Max when sculpting is finished?

-Is there a better workflow to align these objects than my current workflow? Should I bake with some other software instead than substance? I think its quit easy to bake in SP because of "baking by mesh names" as then I don't have to separate objects.

Thanks!

Replies

  • pior
    Offline / Send Message
    pior quad damage
    Hello -

    • First things first, forget all about the end of the pipeline for now (baking). Your workflow currently has a fundamental issue related to model scaling, which should be taken care of first and foremost. Spend a day focusing on this alone, to precisely understand which part of your process creates the error. It should be possible for you to go back and forth between max and zbrush without ever having to rescale your models. Your FBX export/import settings are probably applying a scale factor (either actually transforming your models, or adding a scale factor as "flag". This kind of band-aid feature can be useful to salvage models coming from different sources, but in your case you want to work as cleanly as possible).

    • Now when it comes to editing the alignment of models before baking : Toolbag 3 is perfect for that, since it is the only baking tool out there allowing you to manipulate models with full visual feedback.
  • kanga
    Offline / Send Message
    kanga polycounter lvl 10
    Thats great advice from Pior.
    Also something you could do is
    1/ Check the 'Units Setup' under customization in Max, its in the main menu. Mostly Display Unit Scale is set to centimeters (for Europeans making character sized models:)  ). For exporting, press the 'System Units Setup' button and set 'System Unit Scale' to 1 unit equals one centimeter.
    2/ Make a box in max to the scale of whatever it is you are going to model. For a character that might be 0.5m x 0.5m x 2m tall. Then centre the box on the grid in Max.
    3/ Open ZBrush and setup a document you will use for the ZBrush part of your project. Set a primitive on the canvas then change all the settings you need to. Set the scale to 100 in the Export pallet under the tool menu. Save the document  in your programs 86 folder/ pixologic/ ZBrush/ ZProjects.
    4/ Go back to Max and press the GoZ button with the box you made earlier selected.
    5/ Go to ZBrush and the Max box will be in a document at 100 too big. Ignore that and open the lightbox, find the document you saved there, double click it and open the subtool pallet and append the Max box. If you want change something on the box and GoZ it back to Max for a test.

    You have setup Max and ZBrush to work in sync. You cant perfectly align your models by hand. Let the software do that for you.

    Hope that helps. Cheerio.
  • M u r t t i
    Offline / Send Message
    M u r t t i triangle
    Thanks a lot for your comments pior and kanga!

    I will try these out and come back to tell if that worked!
  • M u r t t i
    Offline / Send Message
    M u r t t i triangle
    Hello again,

    I guess the problem was with 3ds Max import settings. I changed scale factor from inches to centimeters and now scale is the same. Thanks!

    One more question. When I have my mesh decimated in Zbrush it has total 930k polygons. When it's imported to max it has 23M tris. I understand that polygons and tris are different things but why does the tricount increase so much when imported to Max? I guess decimation is needed to make file sizes smaller and to make it easier for Max to use it but right now Max is very laggy and crashes quite a lot when importing HP mesh. 

    Is there some other factor I should check when importing HP mesh? Why does Max create this "extra" geometry for imported mesh?
  • Obscura
    Offline / Send Message
    Obscura ngon master
    Its possible that "turbo smooth" is enabled in the import settings.
  • M u r t t i
    Offline / Send Message
    M u r t t i triangle
    Obscura said:
    Its possible that "turbo smooth" is enabled in the import settings.
    Checked that and there is no turbosmooth in import settings. Current settings are these:


  • musashidan
    Offline / Send Message
    musashidan sublime tool
    Turbosmooth is only an export setting in Max. ZB is in point count. This will double in Max so it should only be about 1.9m in Max. Not sure what you're doing wrong but it is a very straightforward process. Have you tried with .obj?
  • M u r t t i
    Offline / Send Message
    M u r t t i triangle
    Turbosmooth is only an export setting in Max. ZB is in point count. This will double in Max so it should only be about 1.9m in Max. Not sure what you're doing wrong but it is a very straightforward process. Have you tried with .obj?
    I managed to export HP mesh from Zbrush using GoZ. After that I made few modifications and exported LP to Zbrush to check that alignment was okay. Now I am facing new problem in Subtance painter after I have baked HP to LP. When baking is ready mesh seems to be okay but when I click (push mouse1) some parts of the mesh disappears. When I release mouse1 everything is shown again. Any idea why this happens? See pics below.

    PS. I know there is still some adjustment needed to get better bake put this is just sample what the mesh looks like right now.

    Baked mesh in SP:


    And then when I push mouse1 and hold it down:





  • M u r t t i
    Offline / Send Message
    M u r t t i triangle
    I noticed that SP is creating several texturesetlists instead of one when importing LP model in. I guess that is the problem but how to avoid this?
  • Dumbanana
    Offline / Send Message
    Dumbanana polycounter lvl 7
    So as I understand it to work, Substance Painter is going to take whatever materials you have assigned to your LP mesh and make those into your TextureSet options or shaders.

    Basically you want to break up your UV sets with a material.  If for example, your LP mesh is going to be using only one texture set, then assign your whole LP mesh one material.  If you have a mesh and its split up across more then one UV set, then you'll want to assign each UV set to its own material, so that when you export and import into Substance Painter you get multiple materials/ textureSets to choose from within Painter.

    This video might provide more info: 

    Hope that makes sense and helps.
  • musashidan
    Offline / Send Message
    musashidan sublime tool
    There's an option in settings to 'only display selected material when painting'. Disable it.
  • M u r t t i
    Offline / Send Message
    M u r t t i triangle
    There's an option in settings to 'only display selected material when painting'. Disable it.
    Thanks! This worked but why do I have several texturesets at the moment on my mesh eventhough I have unwrapped whole mesh together in 3ds max?

    Right now texturesets are not working properly. For example my pillars are separated into two sets and it makes it harder to paint same wooden texture on the whole pillar as I need to do it on two different sets. Is there way to combine these sets?

    EDIT: I did some modifications to polygons and re unwrapped those parts. Now I have whole mesh in one textureset :)
  • M u r t t i
    Offline / Send Message
    M u r t t i triangle
    I ran into a new problem. I got pretty decent results when baked HP to LP in Substance painter but low poly mesh polygon edges are showing on top of my baked mesh (see picture). I tried to prevent this by using textools in Max and applying "smoothing groups from UV shells" but it didn't help. I've also tried to adjust ray distance in SP but it didn't help either. Is there some other way to fix this?




Sign In or Register to comment.