Substance Painter to UE4 sRGB Error / Roughness Issue?

polycounter lvl 4
Offline / Send Message
hmm_rock polycounter lvl 4
Hi guys, I apologize if this has been answered before, but I've been researching my problem and could use a little more direction. My roughness texture in UE4 look vastly different from SP. From what I understand I need to uncheck the sRGB option in the texture parameters (I've read for "BaseColor and Roughness" and "everything but BaseColor" so not sure on which exactly), but doing so causes and error in the material that results in the material being over-ridden with the default UE checker texture. Maybe I'm unchecking sRGB in the wrong place? Could this be an error in my export from SP? Is it a disparity in the lighting between the two programs? Any help is really appreciated! :)

(Also bonus question that I should probably just research, what normal setting should I be using/exporting for UE4 from Substance? DirectX or OpenGL?)

Substance Painter
HNT8ezZ.jpg?1

UE4
dJLjJLj.jpg?1

Replies

  • Bek
    Offline / Send Message
    Bek polycounter lvl 5
    If you look in painter under layer settings (for memory) it will list each texture type you have in your document (base colour, roughness, height...) as well as what format they are in. By default only base colour will be sRGB. Match that in UE4. You might have to check output settings too as it might be converting stuff there. There's a UE4 preset too I think.
  • LMP
    Offline / Send Message
    LMP polycounter
    For Normals they should be DirectX for Unreal Engine.
  • Froyok
    Online / Send Message
    Froyok Polycount Sponsor
    hmm_rock wrote: »
    Hi guys, I apologize if this has been answered before, but I've been researching my problem and could use a little more direction. My roughness texture in UE4 look vastly different from SP. From what I understand I need to uncheck the sRGB option in the texture parameters (I've read for "BaseColor and Roughness" and "everything but BaseColor" so not sure on which exactly), but doing so causes and error in the material that results in the material being over-ridden with the default UE checker texture. Maybe I'm unchecking sRGB in the wrong place? Could this be an error in my export from SP? Is it a disparity in the lighting between the two programs? Any help is really appreciated! :)

    (Also bonus question that I should probably just research, what normal setting should I be using/exporting for UE4 from Substance? DirectX or OpenGL?)

    Substance Painter
    [IMG*]http://i.imgur.com/HNT8ezZ.jpg?1[/IMG]

    UE4
    [IMG*]http://i.imgur.com/dJLjJLj.jpg?1[/IMG]

    The error in the shader is because you changed the color space of the texture (the color space is indicated below the texture in the texture sample node properties). Simply recreate the texture node of the use the little arrow to reassign the texture and your material should be able to compile.
    Bek wrote: »
    If you look in painter under layer settings (for memory) it will list each texture type you have in your document (base colour, roughness, height...) as well as what format they are in. By default only base colour will be sRGB. Match that in UE4. You might have to check output settings too as it might be converting stuff there. There's a UE4 preset too I think.
    The color settings in the texture set properties is just an indicator of how we store the data, not how we handle it. So roughness will always we computed and exported as a Linear texture in Substance Painter.

    LMP wrote: »
    For Normals they should be DirectX for Unreal Engine.
    Indded, and you can also flip the Green channel (Y) in the texture properties in UE4.
Sign In or Register to comment.