SOLVED: Drag & Drop of images not working inside PS CC

polycounter lvl 3
Offline / Send Message
DerRazputin polycounter lvl 3
I'm using the latest Photoshop CC release (2014.2 at this point) and whenever I boot it with Quixel it won't let me drag & drop any files into PS.

I tend to open files this way most of the time, so it'd be good to know if there's a way to get this working or even if this behavior is intended for some reason.

I recall that there have been some problems with Quixel due to Photoshop's language being set to something other than English. So it might be useful to know that this is the case for my Photoshop.

Sorry if this has been answered before as it seems like a very basic issue to me. Nevertheless couldn't find anything on the topic. :/

Replies

  • Wiktor
    Offline / Send Message
    Wiktor polycounter lvl 9
    That's very strange, I'm drag dropping all the time. Does this happen when just the SUITE is running or when NDO or DDO is running as well?
  • DerRazputin
    Offline / Send Message
    DerRazputin polycounter lvl 3
    Hey, thank you for your reply.
    Just having the SUITE running breaks the drag & drop functionality. Even if I close it, I still have to restart Photoshop without the suite to make it work again.

    Didn't mention that I'm using Win 8.1 64-Bit. Adobe apps are installed onto my system SSD while DDO rests on another HDD where I keep most of my programs.

    I'm also running PS in English now. Makes no difference, though. I still have to open images in a viewer, copy pixels, then paste inside PS, etc if I want to drop stuff onto the canvas.
  • hugojackson18
    Same for me here. It looks like the SUITE changes the settings of Photoshop when you start it with, and things like the OpenGL and History are changed. It would be good to still be able to drag and drop files, as it's an awesome feature of photoshop and it's a shame to lose it when using the SUITE
  • Wiktor
    Offline / Send Message
    Wiktor polycounter lvl 9
    Super weird. I'm running Win 8.1 64-bit as well. Also got PS installed on my SSD. Does it matter if you start Photoshop by launching the SUITE or launching Photoshop and THEN the SUITE?
  • CKohl
    Offline / Send Message
    CKohl polycounter lvl 7
    Are you by chance running Photoshop or SUITE as Admin? In Windows you cannot drag and drop files from a process that is running with lesser privileges into a process that has elevated privileges, so explorer.exe (desktop, task bar, file browser) won't be able to drag into something running as admin because explorer.exe itself does not run as admin and cannot be run as admin without risky hacks.

    I found this out when I was running Skype and Firefox as admin (for reasons I cannot remember) and drag+drop wasn't working and it was driving me insane for days. It took a lot of Googling to find out what was going on but it was instantly fixed as soon as I stopped running them as admin.
    Same for me here. It looks like the SUITE changes the settings of Photoshop when you start it with, and things like the OpenGL and History are changed.

    I've seen this happen once or twice but it usually stabilizes and rarely does that again unless there's a severe PS/SUITE lockup/crash.
  • DerRazputin
    Offline / Send Message
    DerRazputin polycounter lvl 3
    @CKohl: SOLVED! You got me: I had it running in admin mode the whole time. Now it's working. Thank you so much!

    Sorry, I didn't mention it earlier: Must've turned it on to fix some other issue and then forgot to turn it off. I checked the install directory and the individual apps (NDO, DDO, 3DO) are still set to Admin mode (I might've done that too, ha). Doesn't seem to be a problem though. It's only the SUITE that produces this issue when running in Admin mode.
  • Eric Ramberg
    cKohl you´re the man!

    Thank you for reporting this as solved DerRazputin! much appreciated!
  • Wiktor
    Offline / Send Message
    Wiktor polycounter lvl 9
    Woo! Thanks CKohl. :)
Sign In or Register to comment.